Need injectors soon - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-2013, 02:32 PM
Premium Member

 

Join Date: Jun 2013
Location: Lubbock Texas
Posts: 148
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Want injectors soon

My pickup has developed a first start miss that goes away as it warms and putting my foot in it a little. I assume with 190k on the stock injectors it may be a poppet valve. I want to add mods over time when I can afford to but it looks like I start with injectors. I wanted to go with 238/80 or 100 hybrids but was wondering if they can be tuned down till I upgrade the turbo, trans etc? I plan to build a 500+ dd all around fun truck but can't just drop 10k in the process. That's why this will be an ongoing build and I only want to buy injectors once. I don't have a lot of mods done yet but I'm back to work and would like to get after it before it starts getting cold and gives me problems cold starting. Any advise is appreciated.

Last edited by Redrock2000; 08-18-2013 at 06:14 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-17-2013, 04:13 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 5,914
Thanks: 28
Thanked 29 Times in 27 Posts
Feedback Score: 0 reviews
Might change the title from "Need" to "Want" new injectors.

What testing have you done to decide you need new injectors?
Reply With Quote Quick reply to this message
  #3  
Old 08-17-2013, 05:38 PM
Premium Member

 

Join Date: Jun 2013
Location: Lubbock Texas
Posts: 148
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Haven't done any testing just that the stock injectors have 190k on them and the miss goes away after the engine warms up and you give it about 3/4 throttle. I really just assume it was a worn poppet valve and the fact that I did " want" to replace the injectors sooner or later. It only misses first morning startup it doesn't do it at all the rest of the day. Thanks for the reply and any help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:51 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors