I'm worried, Edge Evolution II stuck on 89% - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 04-27-2013, 07:16 AM Thread Starter
Powerstroke.org Rookie
 
mtmc's Avatar
 
Join Date: Dec 2012
Location: Louisville, KY
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm worried, Edge Evolution II stuck on 89%

Okay I have a 2002 F250 with the 7.3. Well I bought a edge evolution II programmer for it. Supposedly it was used but when I received it, everything was still in the factory plastic and looked an smelled new. It's not VIN locked or anything and the diagnostics and monitoring worked like a charm. Anyway, now I'm trying to load the level 1 tow program on it and everything was going great until it got to the Writing Section 4 of 4 and it's been stuck on 89% for about 20 minutes. I'm worried and dont want to turn the key off or unplug it with fear that it will screw up the PCM. What do I do? It's Saturday and edge isn't open to ask them. : (


2002 F250 CCSB True Blue L2

• 5" Turbo Back MBRP, 7" Tip • Muffler Delete • Spectre CAI • Foil Delete • Edge Evolution II • Glowshift Gauges • Hutch/Harpoon Mod • Leveled • 285/75 Cooper AT3 • 16x8 Dick Cepek DC2 • Mile Marker 449SS • Goodmark 2" Steel Cowl • SS Step Bars
mtmc is offline  
post #2 of 6 Old 04-27-2013, 12:52 PM
Serving Our Country!
 
JSchuricht's Avatar
 
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,967
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 25 Times in 24 Posts
Feedback Score: 2 reviews
I would give it a hour. If it hasn't moved at that point you don't have much choice but to turn the key off. If your lucky you will be able to retry the burn. If your not so lucky, you will need to tow the truck to a dealer to have it re-flashed and pay to have the edge unlocked.

JSchuricht is offline  
post #3 of 6 Old 04-27-2013, 01:04 PM Thread Starter
Powerstroke.org Rookie
 
mtmc's Avatar
 
Join Date: Dec 2012
Location: Louisville, KY
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok so it sat on 89% for over an hour so I decided to pull the trigger and unplug it from the OBD port. I then turned the key off and tried to start it and noticed I didn't hear all of the normal priming at startup. So it was just cranking and cranking and never did start. So I went inside and tried to use the Fusion software that came with it. It kept getting hung up and telling me it couldn't access some .dll file. So after finally finding an updated version of the fusion software on edge's website, I was able to update the tuner. It prompted me to try it on the truck and when I did, thankfully it gave me a message that the previous tune was unsuccessful. I loaded the stock tune back on it and everything is so far so good. I assume the update was what was needed but I'm still a little gunshy and not sure if I should try the tune again or not.

2002 F250 CCSB True Blue L2

• 5" Turbo Back MBRP, 7" Tip • Muffler Delete • Spectre CAI • Foil Delete • Edge Evolution II • Glowshift Gauges • Hutch/Harpoon Mod • Leveled • 285/75 Cooper AT3 • 16x8 Dick Cepek DC2 • Mile Marker 449SS • Goodmark 2" Steel Cowl • SS Step Bars
mtmc is offline  
post #4 of 6 Old 04-27-2013, 01:07 PM
Premium Member
 
rdaffin's Avatar
 
Join Date: Oct 2012
Location: New Waverly, Tx.
Posts: 233
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Go for it. Update should have solved the problem.

Sent from AutoGuide.com App

2004 CCSB 4x4, blue spring, SCT , 4" exhaust, Gearhead tunes, egr delete, ELC-1, Coolant filter, ARP Studs, CCV Mod, 6" lift, 35" Toyo A/T II.


rdaffin is offline  
post #5 of 6 Old 04-28-2013, 12:52 PM
Member
 
Ace7.3's Avatar
 
Join Date: Apr 2010
Posts: 73
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I've had this problem with mine a few times. Unplug the edge, turn key off, plug edge back in, follow prompts to go to main menu. Then retry changing power levels. And speaking of updates, I need to check mine

2002 3/4 Lariat,DIY,Zoodad,boost fooler,CCV,HPX,EBPV,Wicked wheel,Auto Meter gauges,Edge Evo II 100 horse,MBRP 4",203*
Ace7.3 is offline  
post #6 of 6 Old 04-28-2013, 01:37 PM
Compression Ignition Addict
 
Join Date: Sep 2011
Posts: 4,357
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 46 Post(s)
Thanks: 6
Thanked 137 Times in 130 Posts
Feedback Score: 2 reviews
letting something sit for that long is worse than just unplugging it and letting it go into recovery. glad you didn't smoke your pcm!
drunk on diesel is offline  
Reply

Tags
7.3 , edge , evolution , stuck

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome