Question for you Evolution 2 guys. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-01-2008, 03:32 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question for you Evolution 2 guys.

I just installed the EVO 2. Love it! However, on the site it says L1 is 60HP, L2 is 80HP and L3 is 100HP. The manual says L1 is 0HP (trans), L2 is 60HP, and L3 is 100HP. My module tells me L1 is tow, L2 is race and L3 is extreme. I have read here in previous posts from last year (i use the search button quite often) that you have to upgrade to get the 60, 80, 100. Well I never did that. So what tunes exactly do I have? My rig is a 2002 F350 dually 7.3L with the 6 speed manual tranny. Did it recognize that and offer up the 60, 80, 100? Or do all latest modules ship this way? Or do I still have the trans, 60, 100 tunes? I am just curious. I just put it on L3. I haven't tried anything else.

Thanks in advance! Oh yeah, one more thing.... I love this site! You guys have a ton of info here.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-01-2008, 08:59 PM
Member
 

Join Date: Apr 2007
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where did you read you have to upgrade to get the 60hp tune? I never upgraded and when mine is on the first level its very obvious that there is added horsepower and torque over stock.
Reply With Quote Quick reply to this message
  #3  
Old 02-01-2008, 09:20 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just read that the first level is trans only in the manual. ill see if i can find the link where i saw it here also later and post it. i was just curious at the time i installed it. i have since changed it and noticed the difference.

thank you. i feel a bit better now. wasn't exactly sure at first.
Reply With Quote Quick reply to this message
  #4  
Old 02-02-2008, 09:37 AM
Member
 

Join Date: Apr 2007
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I know in the gas rigs the first level is a trans only level and it doesnt add any performance.
Reply With Quote Quick reply to this message
  #5  
Old 02-02-2008, 03:47 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just my luck.... I haven't even had it 24 hours and I am already having problems with it. I noticed this morning that the module is turning off while I am driving. Truck still runs fine but the module just shuts off. I have to disconnect the OBD cable and reconnect then it starts working again. Can't call Edge Tech Support until Monday. Tried updating it but it wont connect to the the device. That could be my laptop though. Its not the greatest. Anyone ever done the diagnostic self test on the evo before? just curious what the communication test is supposed to report back if anything. all i get is a blank screen.
Reply With Quote Quick reply to this message
  #6  
Old 02-04-2008, 05:14 PM
Powerstroke.org Rookie
 

Join Date: Sep 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well I just wanted to post that Edge called me first thing this morning and helped me troubleshoot my problem. They are sending me a cable to replace the one I have. They think that is the problem. If that doesn't fix it they will send out an entire new module to replace it. That is awesome customer service. Granted we all expect "this kind" of service with a new product but we seldom receive it with anything these days. So I am happy.

I just wanted to update the forum in case others happen to search for the same issue.
Reply With Quote Quick reply to this message
  #7  
Old 02-05-2008, 03:49 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just got a Evo 2 and love it. I had the same question about the HP and level settings. Per Edge the manual is old and the correct HP are 60, 80, 100. Currently I am using the L2 80hp setting and have no problems
Reply With Quote Quick reply to this message
  #8  
Old 02-05-2008, 03:53 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,242
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Debo View Post
Well I just wanted to post that Edge called me first thing this morning and helped me troubleshoot my problem. They are sending me a cable to replace the one I have. They think that is the problem. If that doesn't fix it they will send out an entire new module to replace it. That is awesome customer service. Granted we all expect "this kind" of service with a new product but we seldom receive it with anything these days. So I am happy.

I just wanted to update the forum in case others happen to search for the same issue.
i had bought the edge evo 2 and had good luck with it , im actually was gonna set it to stock tune and just use it as gauges, and i bought a custom tune set up from tony wildman , mine also started just shutting off just whenever it wanted to, let me know what it takes to get it fixed
Reply With Quote Quick reply to this message
  #9  
Old 02-05-2008, 07:40 AM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: Knoxville TN
Posts: 515
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
okay so is the evo 2 better than a ts with tony tunes? Can you get tony tunes on an evo 2?
NOT TRYING TO HI JACK JUST CURIOUS SORRY
Reply With Quote Quick reply to this message
  #10  
Old 02-05-2008, 08:33 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: WAY north Texas
Posts: 2,386
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
DP tuner was the only one that i know of who could program the evo2. I called jody and asked if he still programs them and he said edge pulled the plug on his programming and he no longer does it. I got my evo 2 in the mail yesterday and will install it this weekend.

I figured that when i am ready for more, I will keep the evo as gauges and a code reader then talk to tony for a custom chip. for you guys wanting to do this now or later like me, make sure that you return the evo to stock or bad things will probably happen!

tonys tunes are going to be better then the evo for sure. i got the evo because i dont like the many gauge look, i want a code reader and i got it for a SWEET deal i could not say no to!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors