Isspro EGT Gauge Spike on Start, take a look at gauge readings - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2008, 02:11 PM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Maine
Posts: 281
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Isspro EGT Gauge Spike on Start, take a look at gauge readings

I just installed my Isspro Gauge kit from dieselmanor. When turning my key to the on position for my GPs to cycle the gauge spikes up to 300 then back down. When running the truck the EGT seems to response accurately and quickly. My gauges are reading the following, hope someone can confirm this readings and if they are on target of what they should be.

My truck is stock:

EGT at WOT 900-1000 degrees
EGT at idle 300-350
Boost 3-5 psi at around 55mph not getting on it
Boost 17 psi at WOT
Trans temp about 130 when warmed up
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-25-2008, 02:13 PM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: Scituate, Massachusetts
Posts: 1,395
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
everything you listed sounds like my truck exactly. I think your good.
Reply With Quote Quick reply to this message
  #3  
Old 01-25-2008, 02:19 PM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Maine
Posts: 281
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by PSDfan99 View Post
everything you listed sounds like my truck exactly. I think your good.
I thought the numbers looked good but had to ask to be sure, my real concern was if the spike in the egt was normal with key in on position.
Reply With Quote Quick reply to this message
  #4  
Old 01-25-2008, 02:41 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: reading,pennsylvania
Posts: 357
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to pinkfloyd
It's probably just the spike in curent since they are electronic guages. mine does the same thing too.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:59 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors