Help with my combo. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-23-2007, 01:19 PM
Member
 

Join Date: Dec 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help with my combo.

Hey all! It's my 1st time here. Great forum!! I would like some of you guys to critique my combo & let me know what you think. I have a late 99 f-250 w/ a 7.3 & automatic trans, 4wd, crew cab, flat bed. It's my work truck/welding rig. I have a 1400lb lincoln welder on the back & about 1000lbs of additional tools on it. I run 33" tires with stock gears. Anyway, I installed a banks 6-gun, mbrp 4" turbo back exhaust, banks wastegate actuator, cold air intake kit & a banks transcommand. I run full synthetic oil in the engine. Anyway. under part throttle it runs ok & pulls pretty decent on any power level from about 3 & up. But under full throttle, it doesn't seem to pull any harder & possibly less than part throttle. I took it to a friends tranny shop & had him test drive it & he thought the trans felt fine. I thought it was slipping. I just recently upgraded my welder which added 700lbs & now under hard acceleration, I feel a shutter coming from somewhere. Is this a converter/trans problem? Also, with the above listed mods, I can't get more than 19lbs of boost no matter what. Is this normal? This is my first diesel & I need some education on how they perform. Thanks for your help! Bill.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-23-2007, 01:22 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: Tulsa, OK
Posts: 4,230
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Welcome to the site, remember this of all things, turbos start to kick in about 2200 RPMS and up, the shudder could be a u-joint maybe or something in the tranny about to out...

have you tried it without the trans command?
Reply With Quote Quick reply to this message
  #3  
Old 12-23-2007, 01:25 PM
Powerstroke.org Sponsor

 

Join Date: Oct 2006
Location: Ventura County, CA
Posts: 20,359
Thanks: 23
Thanked 23 Times in 14 Posts
Feedback Score: 2 reviews
Send a message via AIM to Raul@Stealth Automotive
with the above mods you should see mid 20's for boost... you could possibly have a boost leak somewhere... if it was me i would ditch the banks 6 gun and get yourself a custom tuned chip.. .i can get you a tony wildman chip with 2 tow settings(heavy and light tow) with that amount of weight your always carrying i would suggest you have both of those tunes.... let me know if you have any questions.... oh and welcome to the Org
Reply With Quote Quick reply to this message
  #4  
Old 12-24-2007, 12:58 AM
Member
 

Join Date: Dec 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks guys! Stroker, I have not tried it without the Transcommand. Now that you mention it, is there any way to get rid of the "off idle lag" for lack of better words? Raul, I would like to keep the six gun for the porpose of the boost & egt readings it supplies. But I am open to stacking another chip on top of it if that works. what kind of gains can be expected from Tony's chip over the banks? Thanks, Bill.
Reply With Quote Quick reply to this message
  #5  
Old 12-24-2007, 06:47 AM
John Wood Nut Swinger

 

Join Date: Jan 2007
Location: too far from Texas
Posts: 3,410
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
The banks is good for a max of 65hp. The TW chip can make over 100hp. If you go that route turn the banks down to 0 and run the chip on whatever tune you want. Stacking the 6gun and the TW chip will not gain much. The most I have seen the banks help in a stocking combo was 9hp.

If you go with a TW chip ask about tuning for a H2E turbo to aid in spool up. Or get a DP tuner and get his H2E tuning. I have DP tuner with tunes for an H2E turbo and my turbo(bigger and heavier than stock) spools great. I tow quite a bit with it and lag is all but gone with the tuning I have. At 1600 rpm my turbo lights up real nice.
Reply With Quote Quick reply to this message
  #6  
Old 12-24-2007, 08:55 AM
Member
 

Join Date: Dec 2007
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the suggestions guys! Can you guys spell out for me in dummy terms some of the abbreviations? I read some of the other posts here & by the time I was done, I had learned nothing more than before I read them. Lol! What's an h2e turbo? Also, the Banks wastgate actuator is adjustable right? Could it be that I adjusted it incorrecctly & that's where the low boost is coming from? Just trying to learn as much as I can from you guys. Thanks, Bill.
Reply With Quote Quick reply to this message
  #7  
Old 12-24-2007, 09:06 AM
KVFD
 

Join Date: Nov 2007
Location: Kearney, Nebraska
Posts: 4,061
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to redstroker_2002
welcome to the .org bud!!! heres a bump up for ya!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors