Edge CTS - Boost PID Issue - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-25-2012, 02:20 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jun 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Edge CTS - Boost PID Issue

Hey all, i've got just the CTS Insight monitor on my '02 7.3L. A few months back I'd occasionally hear a beep on the Insight monitor, but never knew what it was. Now, i know what it is cuz it's getting worse.

What happens (occasionally) is when I'm just about at a stop and the boost PID on the monitor is at zero, it'll start flashing red and beeping a few times then quit. The boost seems to be reading just fine when i'm taking off and this only happens when i'm just about at a complete stop and the boost is at zero. And as i said, sometimes this happens, sometimes it doesn't, but i pretty much can't drive 10 miles w/out it happening along the way....again only when i'm coming to a stop.

Anyone ever have an issue like this? Talked to the guys at Edge, they had me try a firmware download for some other issue and it did not work. So plan on calling them this week and hopefully getting the monitor replaced.

Unless anyone has any experience or ideas on this that it could be an actual issue with the turbo?

Thanks, D
Dz02F250 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome