Not impressed with SWAMPS!!! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-04-2012, 10:06 AM
Serving Our Country!

 

Join Date: Mar 2007
Location: In the Country
Posts: 729
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry Not impressed with SWAMPS!!!

Installed Swamps stage 1 single shots and custom tuned TS chip on my truck last week. I've been holding out writing this hoping that I would learn to like them. My first issue is with the check engine light that will not shut off and cannot be cleared as there are no codes to read. Second my truck was way faster with my normal TS chip, the extreme tune on this new one is of no comparison to the 140 hp on my last one. And the straw that broke the camels back, I tow a lot and I'm currently hooked up to a fully loaded dump trailer, while stopping at a stop light my truck decided to turn off. There is nothing scarier then rolling down hill into a busy intersection without power brakes. When I come to stops the truck has been hitting a real low idle but I figured it was all apart of the chip and they would know how to tune it properly. Seriously pissed right now.

Any one have experiences with swamps?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-04-2012, 10:15 AM
Compression Ignition Addict


 

Join Date: Jan 2012
Location: Libery Lake, WA
Posts: 464
Thanks: 11
Thanked 6 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Stroker7.3 View Post
Installed Swamps stage 1 single shots and custom tuned TS chip on my truck last week. I've been holding out writing this hoping that I would learn to like them. My first issue is with the check engine light that will not shut off and cannot be cleared as there are no codes to read. Second my truck was way faster with my normal TS chip, the extreme tune on this new one is of no comparison to the 140 hp on my last one. And the straw that broke the camels back, I tow a lot and I'm currently hooked up to a fully loaded dump trailer, while stopping at a stop light my truck decided to turn off. There is nothing scarier then rolling down hill into a busy intersection without power brakes. When I come to stops the truck has been hitting a real low idle but I figured it was all apart of the chip and they would know how to tune it properly. Seriously pissed right now.

Any one have experiences with swamps?

Have you contacted Swamps to see if they can adjust the tunes??
Reply With Quote Quick reply to this message
  #3  
Old 12-04-2012, 10:49 AM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Texas
Posts: 1,565
Thanks: 14
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
Who did the work, and did you call Swamps? My first step would to be to work it out with the vender before jumping on the forum.
Reply With Quote Quick reply to this message
  #4  
Old 12-04-2012, 03:28 PM
Member
 

Join Date: Jul 2011
Location: St Pete
Posts: 70
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
from what your saying i would recheck your chip and make sure its properly seated all the way. also since your just did injectors double check your valve cover harness inside and out. i say this because when i did my glow plugs i had a huge lope problem along with the motor cutting out. Turned out to be a bad ground on the valve cover connection. Like others say dont go blasting it on the forums, check with swamps first.
Reply With Quote Quick reply to this message
  #5  
Old 12-04-2012, 04:53 PM
Compression Ignition Addict
 

Join Date: May 2011
Location: East Tennessee
Posts: 693
Thanks: 0
Thanked 16 Times in 4 Posts
Feedback Score: 9 reviews
Definitely call Swamps - In my experiences with them, they've been more than helpful and have gone above and beyond to make things right!
Reply With Quote Quick reply to this message
  #6  
Old 12-05-2012, 04:12 AM
Coal Rolling = Posing

 

Join Date: Nov 2007
Location: Cumberland Furnace, TN
Posts: 9,872
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Stroker7.3 View Post
Installed Swamps stage 1 single shots and custom tuned TS chip on my truck last week. I've been holding out writing this hoping that I would learn to like them. My first issue is with the check engine light that will not shut off and cannot be cleared as there are no codes to read. Second my truck was way faster with my normal TS chip, the extreme tune on this new one is of no comparison to the 140 hp on my last one. And the straw that broke the camels back, I tow a lot and I'm currently hooked up to a fully loaded dump trailer, while stopping at a stop light my truck decided to turn off. There is nothing scarier then rolling down hill into a busy intersection without power brakes. When I come to stops the truck has been hitting a real low idle but I figured it was all apart of the chip and they would know how to tune it properly. Seriously pissed right now.

Any one have experiences with swamps?
Step 1: Call whoever you bought the injectors and chip through.

Step 2: Call Swamps directly if the dealer is no help.

Step 3: Call Swamps and thank them for straitening your issues out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors