overboost issue now no power - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-11-2012, 11:21 AM
Member
 

Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
overboost issue now no power

my truck a 1999 f250 7.3 auto has got an issue the truck runs beautiful starts great when cold but i always had a problem with overboost on kick down or hard accelration so trip check engine light and fall on its face i connected a boost controller in the map line and preset it at 22 psi as baseline now the truck dont even spool up ill get maybe 12 psi boost and no power is there something else im missing? what have yall done to resolve overboost thanx
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-11-2012, 01:06 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2011
Posts: 140
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Do a DIY boost fooler for around 10 bucks
Reply With Quote Quick reply to this message
  #3  
Old 01-11-2012, 02:16 PM
Member
 

Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Boost fooler

The bo ost controller acts like a boost fooler so dont know what the prob is
Reply With Quote Quick reply to this message
  #4  
Old 01-11-2012, 03:20 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Posts: 823
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What did you use to calibrate the regulator? Might double-check the calibration again, or drop the pressure the reg is allowing through a few PSI for testing.
Reply With Quote Quick reply to this message
  #5  
Old 01-11-2012, 06:13 PM
Member
 

Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
To calibrate it I put an air pressure gauge on one end and put compressed air on the other then turned the nob to desired pressure then connected it on the map line set at 22 psi I don tget any codes just no power
Reply With Quote Quick reply to this message
  #6  
Old 01-14-2012, 07:50 PM
Member
 

Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
prob fixed

the prob started after i put the boost fooler in and turns out the EBP sensor went bad at the same time she back up and runnin strong
Reply With Quote Quick reply to this message
  #7  
Old 01-14-2012, 10:29 PM
Compression Ignition Addict
 

Join Date: Jun 2011
Posts: 152
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
If u don't mind me asking how did u know it was the Ebp sensor.how did u test it thanks in advance
Reply With Quote Quick reply to this message
  #8  
Old 01-15-2012, 07:17 AM
Member
 

Join Date: Jul 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ebp sensor

I had scanned for codes and finally I got one resulting in ebp sensor nalfunction cuz I already replaced the ebp tube so I replaced the sensor its back to normal
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors