140hp injectors.. anyone have problems with idle??? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-04-2007, 10:52 AM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: denver, colorado
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy 140hp injectors.. anyone have problems with idle???

Was just curious if anyone else who has bigger injectors ever has problems with them. I bought 140hp injectors for the new motor and it runs rough at idle, almost like it's loading up with fuel. Funny thing is, it runs rough all the time in stock mode with no chip, and still runs rough with my old edge programmer. I put my new sniper 6 pos chip that i got from the same guy that sold me the injectors on it and it clears it up a whole lot, but when your slowing down to stop it idles rough for two or three seconds and then clears up. Oh yeah, no check engine light either.
Anyone else have problems like this?
thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-04-2007, 10:57 AM
Thats Mr. Oil Leak.....

 

Join Date: Oct 2006
Location: Cypress / Houston
Posts: 9,529
Thanks: 4
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to MrJohnWayne Send a message via MSN to MrJohnWayne Send a message via Yahoo to MrJohnWayne
with the stock tuning it's pretty much to be expected. You are spraying alot more fuel into the cylinders vs stock injectors. Why it still does it with the sniper I don't know.
Reply With Quote Quick reply to this message
  #3  
Old 09-04-2007, 12:47 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,089
Thanks: 29
Thanked 38 Times in 36 Posts
Feedback Score: 0 reviews
It should not run rough with the chip because the injectors are a single shot injector... If you pull the chip they are trying to run a split shot program and will idle like crap.

Bigger injectors do not inject any more fuel at idle then a stock one does...

They will run rough for a few seconds if you get on it hard and then lift, alot of fuel, BIG changes in ICP and there ya go.
Reply With Quote Quick reply to this message
  #4  
Old 09-04-2007, 12:50 PM
COLLEGE KID
 
Join Date: Feb 2007
Location: Chicago, IL
Posts: 3,226
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to lifewitlooie
01 F-250 SC PSD, 120,000m, 12 Isspro Gauges, AFE-2,CCV Mod,IAH delete,map reg, GTP-38r 1.15 housing (TN BB Going in soon), 6.0 IC, GTS Hybrid stage 3 injectors, Water injection, Tadd's tune's, SP diesel brake and TC controller, MBRP 4" dual's, 4" exhaust cutout, Aero, 6" tip's, 100 axl tank, 4" Revtek lift, 37-14.50-17 TOYO MT's 401hp and 890tq...

WOW!!!
Reply With Quote Quick reply to this message
  #5  
Old 09-04-2007, 12:51 PM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,087
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by CSIPSD View Post

Bigger injectors do not inject any more fuel at idle then a stock one does...

What injectors make smoke at idle? I was watching some truck pulls a few months back and noticed that.
Reply With Quote Quick reply to this message
  #6  
Old 09-04-2007, 12:53 PM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: denver, colorado
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
But does it sounds right that even with the edge on there it still runs like crap? I understand why it runs like that stock, but even with the programmer? I understand why it idles rough when you get on it and then let off, it's basically loading up. When i ran the buzz tests everything came up fine, but if i run a contribution test, it's coming up #8 cylinder. Could there possibly be something wrong with my brand new injectors?
Reply With Quote Quick reply to this message
  #7  
Old 09-04-2007, 01:00 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,089
Thanks: 29
Thanked 38 Times in 36 Posts
Feedback Score: 0 reviews
Might be a harness issue... how long have you been running them? takes about a hundred or so miles to get the air out of the system....

The reason it still runs bad with the edge is all the edge is doing is reflashing a split shot program with a differant split shot program...

As far as bigger injectors smoking at idle, that could be a tuning issue or a tip issue... But for a DD type injector there should be little if any added fuel at idle.
Reply With Quote Quick reply to this message
  #8  
Old 09-04-2007, 01:00 PM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: denver, colorado
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey CSIPSD,

let me see if i understand..... So stock injectors are split shot injectors. So.. when you go bigger they are single shot? What's the difference between the two? I know you're very knowledgeable about this, that's for the help.
Reply With Quote Quick reply to this message
  #9  
Old 09-04-2007, 01:05 PM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: denver, colorado
Posts: 302
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by CSIPSD View Post
Might be a harness issue... how long have you been running them? takes about a hundred or so miles to get the air out of the system....

The reason it still runs bad with the edge is all the edge is doing is reflashing a split shot program with a differant split shot program...

As far as bigger injectors smoking at idle, that could be a tuning issue or a tip issue... But for a DD type injector there should be little if any added fuel at idle.

The harnesses are brand new. Pretty much everything is brand new. As of right now, i've put about 2500 miles on them since last friday when i put the new motor in. I've had this problem ever since i started it up (new motor). I ran it stock at first, then tried the edge on it with no change, and then a couple days ago i put the 6 pos chip on it. The idle got a lot better with it, even on the stock position in the chip. So basically from now on, if i want to change chips it would have to be a custom burned chip to fit the injectors...?
Reply With Quote Quick reply to this message
  #10  
Old 09-04-2007, 01:08 PM
Compression Ignition Addict
 

Join Date: Oct 2006
Location: Bend, Or
Posts: 6,089
Thanks: 29
Thanked 38 Times in 36 Posts
Feedback Score: 0 reviews
Yup, truck will run, but like crap on split shot programing...

Tell your tuner (be it Tadd, Jody or Tony) that you are running a single shot program and they can build your programs from that. Where did you get the injector that there calling it a 140hp injector? Most PSD injectors are more like a stage 1, stage 2 and hybrid then B codes and so on...

The reason for a single shot injector is it needs less HPO to fire...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:01 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors