Diesel Dynamic Chip through CEL on? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-06-2011, 06:42 PM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Location: Lehigh Valley, PA
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Diesel Dynamic Chip through CEL on?

Hey guys,

I have a diesel dynamics 80hp chip, it was the one that was put in the truck when it was first bought in 2000, long story, but it was my dads friends old truck, and he still had the chip, the 35s, and clear headlights at his house i guess, seems like a pack rat to me, but anyway, he put the chip in for me, and I went from about 10mph to 100 in seconds, it was faster than all my buddies cummins's with the edge chip haha, but once I governed, the check engine light appeared, obviously not a good thing to happen since I got the truck last week lol, so we took the chip out, any ideas on what could of caused this? gauges looked normal

there was also a small "breather tube" that we attached to the turbo.

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-06-2011, 07:11 PM
Supporting Vendor
 

Join Date: May 2010
Posts: 280
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
My guess is you set the P1211 code which means that your high pressure oil pump cannot keep up with the demand.

Believe it or not, it's very likely that Bill Cohron (now Power Hungry Performance) wrote the calibration on that chip.
Reply With Quote Quick reply to this message
  #3  
Old 01-06-2011, 07:25 PM
Powerstroke.org Rookie
 

Join Date: Dec 2010
Location: Lehigh Valley, PA
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by PHPDiesel View Post
My guess is you set the P1211 code which means that your high pressure oil pump cannot keep up with the demand.

Believe it or not, it's very likely that Bill Cohron (now Power Hungry Performance) wrote the calibration on that chip.

So I should probably not use this chip than huh lol
Reply With Quote Quick reply to this message
  #4  
Old 01-07-2011, 07:28 AM
Supporting Vendor
 

Join Date: May 2010
Posts: 280
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
What?

By all means use it! All that code means is that your high pressure oil pump is not able to keep up with the demand of the injectors. It's not going to hurt anything at all.

The only way around that is to drive less aggressively or get a new HPOP or single shot injectors. But with the injectors comes different tuning anyway.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors