Tranny/clutch question - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-01-2010, 07:14 AM Thread Starter
Compression Ignition Addict
 
Join Date: Jan 2010
Location: Washington
Posts: 212
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tranny/clutch question

I have 700 miles on my new south bend clutch, and when i first put it in the truck it had a weird chatter sound while at idle. i was told to let the clutch break in, break in recommended by south bend is 750miles. but the chatter sound has not gone away yet. not sure if its clutch related or another issue. cant tell if it makes the sound while driving either. any ideas?

2000 F250 SD ex cab long bed
6spd trans
south bend 350hp-750lb/ft clutch
6 in lift with 37in Km2 BFG
4in mbrp turbo back single exhaust
TS 6 Pos Chip
DIY intake
SOON TO COME
new injectors
some sort of turbo upgrade
Sullie250 is offline  
post #2 of 3 Old 12-01-2010, 08:00 AM
Compression Ignition Addict
 
Join Date: Jul 2010
Location: Billings, MT
Posts: 466
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just had a clutch put in my truck and I think I have just shy of 1000 miles on it (in 2 days, gotta love my job). I noticed mine does it too, and through some research and poking around on the internet I've found it is fairly common and just happens. I dont remember exactly why, but I don't think its something to worry too terribly about. Someone else will chime in and give the full details I'm sure.

2001 CCLB SRW 6spd - 375K and counting
2003 GMC Yukon - Her baby Hauler
1992 Acura NSX
1997 Honda Civic Hatchback - 2.4 liter, 6266 Turbo

Build Thread for the Honda
ProOnThaSnow is offline  
post #3 of 3 Old 12-01-2010, 06:02 PM Thread Starter
Compression Ignition Addict
 
Join Date: Jan 2010
Location: Washington
Posts: 212
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for the info...i was not to concerned about it, just mainly curious. i know that on some cars/trucks with aftermarket clutches in them that they make the noise too. i just wanted to make sure it was somewhat normal and that nothing was wrong

2000 F250 SD ex cab long bed
6spd trans
south bend 350hp-750lb/ft clutch
6 in lift with 37in Km2 BFG
4in mbrp turbo back single exhaust
TS 6 Pos Chip
DIY intake
SOON TO COME
new injectors
some sort of turbo upgrade
Sullie250 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome