gauges in and batteries drained?? - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-12-2010, 10:58 AM Thread Starter
Compression Ignition Addict
mxracer511's Avatar
Join Date: Aug 2010
Location: Fort Worth
Posts: 219
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to mxracer511 Send a message via Yahoo to mxracer511
gauges in and batteries drained??

so i installed my gauges the other day havent even hooked up pyro and trans sensors yet just ran all wiring to back of gauges and hooked up ground wire and power wire for lighting and the one thats supposed to go to the gauge illumination and the next day when i came out truck would barely start but got it running and disconected both power wires but left ground hooked up next day come out and truck wouldnt start at all got it jumped drove it around for about an hr came back let it sit for a few hrs came back out and dead again juumped it again drove around for awhile shut it off for about n hr n half started up fine came home parked it came out this morning and dead again any one have any ideas?

99 7.3, 6" stacks, 37x13.5 km2s, ev boost, trans temp and egt gauges, 6637 intake, tw tunes, cnc fab 4 line fuel feed kit, hpx, boost fooler, john woods valve body, triple disc billet tq conv, swamps idm, MB hoop, comp cams 910-16 valve springs .030 shims, smith brothers pushrods and PIS 250/200's, PMF stage 2 gusseted trac bars, 4" icon lift
mxracer511 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome