possible stupid question.. - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-21-2010, 09:55 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
possible stupid question..

this is the first powerstroke ive driven and this was also the first trip i had taken it on. BUT i never noticed that it has very little power at low throttle... this came about over the weekend where i went to pismo beach to the ocean dunes. well i went to pull i friend out and half throttle had nuthing, didnt boost just kinda clacked away and never got on the turbo so to speak. so i backed up tryed again but wide open. tons of power and it felt like WOT.. well on the way home i played with the throttle some and noticed it doesnt really have linear throttle response. i know i may be splittin hairs here but it really feels like its 1/4 or wide open nutting really in the middle. this truck is a 01 and it has a banks stinger kit which is a 4" exhaust 1.0 turbo housing and a chip. im saving to change to a diff tuner but if there is something wrong i rather spend it on fixing the problem not covering it up.. but if its just a poorly designed chip well... let it rip then!

and one last thing.. when you install the banks kit they have you ground out a wire that goes to the map sensor.. any idea what this does? i can dig up the instructions if the wire color would help

thanks, josh
froshy00 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-22-2010, 07:20 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
wow.. well could anyone tell me if their truck feels like this? or do they build power pretty smoothly with throttle input? maybe there is a problem with it...
froshy00 is offline  
post #3 of 5 Old 06-22-2010, 07:29 PM
Premium Member



 
7.34ever's Avatar
 
Join Date: Dec 2008
Location: Aberdeen, WA
Posts: 6,449
Thanks: 26
Thanked 50 Times in 42 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 9 reviews
I can see where you're coming from with that being your first diesel truck. I own an 02 7.3 and they are not the hottest at low rpm. Aftermarket parts can make a big difference but I think the problem is you're not used to it yet. It's probable fine.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
12TH Man
Live in WA or OR??? Check out these links.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
7.34ever is offline  
post #4 of 5 Old 06-22-2010, 07:43 PM
Emergency Services

 
Join Date: Mar 2008
Location: W.V.
Posts: 1,674
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i vote for a better chip. tw, or php. also do u have an upgraded air intake?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
19558077 is offline  
post #5 of 5 Old 06-22-2010, 07:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ya i may just not understand it.. but it really seems like its a little throttle for good mileage or wide open for go fast.. mines an automatic but it could be described as trying to start off in 3rd i guess... the engine just doesnt rev up and kinda struggles. i kinda have an upgraded intake.. i did the zoodad and also cut a hole on the driver side of the air box and made it suck air from the fender. and i cut out the separation between the filter and the cold air tube that goes to the front of the truck, which basically made the hole bigger. and i have a conical dryflow filter ima make fit in there as well.. just havnt yet

and im researching the chip and saving.. but its like 500 bucks!!

thanks for the reply's guys.
froshy00 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome