Turn Signals Not Working - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-16-2009, 12:55 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2008
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turn Signals Not Working

My truck didn't come with an owner's manual, so I'm not sure which fuse is for the turn signals. I checked all the 20a fuses and they are all fine.

I located and replaced the flasher relay, still doesn't work.

I replaced the turn signal switch, still doesn't work.

My hazards work fine, lights, high beams, etc. just the darn turn signals.

Any other ideas before I have someone look at any wiring issues/shorts?

My truck is a 2003 F250.

Can anyone tell me which fuse is for the turn signals?

papacito is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome