Non Functioning Turn Signals and Malfunctioning Heat?? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-25-2009, 08:21 AM
Powerstroke.org Rookie
 

Join Date: Oct 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Non Functioning Turn Signals and Malfunctioning Heat??

My turn signals wont work on my 02 SD. The green arrows wont flash on the instrument cluster either but the flashers work fine, inside and out. I thought it may be the whole turn signal/wiper assembly but the wipers work fine, just not the turn signals. Also, my heat/Ac will only come out of the defroster and not the vents no matter what setting I turn it to. It a valve or something else just sticking somewhere in the blower system?

Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-25-2009, 08:49 AM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,575
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Heat out from only the defrost on most vehicles including your PSD means vacuum loss, check the electric vacuum pump mounted under the hood on the passenger side. You should be able the hear it pumping when the key is on and you move the vent selector knob around.

One easy thing to check on the blinkers is to tilt the steering wheel all the way up and see if they work. Mine had a problem with the plug to the multifunction switch was loose, after I figured out it worked when tilted up but not when tilted down I took the column covers off and glued the plug in to the switch so it wouldn’t pull out when tilted down.

You may just have some fuses blown or something simple like that, post back and let us know.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:32 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors