Non Functioning Turn Signals and Malfunctioning Heat?? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-25-2009, 09:21 AM Thread Starter Rookie
Join Date: Oct 2008
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Non Functioning Turn Signals and Malfunctioning Heat??

My turn signals wont work on my 02 SD. The green arrows wont flash on the instrument cluster either but the flashers work fine, inside and out. I thought it may be the whole turn signal/wiper assembly but the wipers work fine, just not the turn signals. Also, my heat/Ac will only come out of the defroster and not the vents no matter what setting I turn it to. It a valve or something else just sticking somewhere in the blower system?

Mayo Dawg is offline  
Sponsored Links
post #2 of 2 Old 02-25-2009, 09:49 AM
Powerstroke Techie

alabamafrog's Avatar
Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,577
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Heat out from only the defrost on most vehicles including your PSD means vacuum loss, check the electric vacuum pump mounted under the hood on the passenger side. You should be able the hear it pumping when the key is on and you move the vent selector knob around.

One easy thing to check on the blinkers is to tilt the steering wheel all the way up and see if they work. Mine had a problem with the plug to the multifunction switch was loose, after I figured out it worked when tilted up but not when tilted down I took the column covers off and glued the plug in to the switch so it wouldn’t pull out when tilted down.

You may just have some fuses blown or something simple like that, post back and let us know.

***My Powerstroke Pics***
“Government, even in its best state, is but a necessary evil; in its worst state, an intolerable one” (T Paine)
Government cannot give anyone anything without stealing it from someone else. (A Frog)

alabamafrog is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome