Need help with my dying 99 powerstroke - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-20-2014, 04:19 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help with my dying 99 powerstroke

I need help my 99 powerstroke is having problems it will kill out well driving every so often but I can always start it back up again I thought it was my cps so replaced it, it went about 500 miles and started happening again put another one in , lasted about 300 miles same thing they were cps from oreilly i now tried couple from ford same thing with first one about 300 miles now on my last one and i put that one in and didnt even last 5 miles and doing same thing im i really getting that many bad cps or is there something else wrong any and all thoughts are appreciated. 
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-20-2014, 05:18 PM
Compression Ignition Addict
 

Join Date: Feb 2014
Posts: 336
Thanks: 1
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Have you checked your icp? Or ipr? Any codes?
Reply With Quote Quick reply to this message
  #3  
Old 07-20-2014, 07:37 PM
DERAIL MOD!!!



 

Join Date: May 2011
Location: Canton and kennesaw
Posts: 21,906
Thanks: 24
Thanked 151 Times in 139 Posts
Feedback Score: 4 reviews
Idm???????
Reply With Quote Quick reply to this message
  #4  
Old 07-20-2014, 07:41 PM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 5,135
Thanks: 474
Thanked 155 Times in 145 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by Powerstrokehopeful View Post
I need help my 99 powerstroke is having problems it will kill out well driving every so often but I can always start it back up again I thought it was my cps so replaced it, it went about 500 miles and started happening again put another one in , lasted about 300 miles same thing they were cps from oreilly i now tried couple from ford same thing with first one about 300 miles now on my last one and i put that one in and didnt even last 5 miles and doing same thing im i really getting that many bad cps or is there something else wrong any and all thoughts are appreciated. 
I bet you have a wire rubbed raw somewhere. Not enough to blow a fuse but kill a sensor or something to knock out ur engine.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #5  
Old 07-20-2014, 08:50 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Iv checked my wires running to my cps and all seem clean and in tacked. Only code other then cam error is a p0603 not sure what that is.
Reply With Quote Quick reply to this message
  #6  
Old 07-20-2014, 08:53 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I also have an edge tuner on it but iv put it back to stock and the same thing killing on me. I tried unplugging my fuel bowl heater tonight and same thing.
Reply With Quote Quick reply to this message
  #7  
Old 07-20-2014, 09:01 PM
Compression Ignition Addict
 

Join Date: Feb 2014
Posts: 336
Thanks: 1
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Check the icp and ipr(both on top of motor, see if they have oil in the electrical part of the sensor when you pull it) and idm(for water coming in or anything of that sort, behind drivers side fender well)
Reply With Quote Quick reply to this message
  #8  
Old 07-20-2014, 09:13 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok ill check that tomorrow. What would that mean if there is oil in, or water in it?
Reply With Quote Quick reply to this message
  #9  
Old 07-20-2014, 09:17 PM
Compression Ignition Addict
 

Join Date: Feb 2014
Posts: 336
Thanks: 1
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
New idm and new sensor wherever it shows, sensors are about $120 each IIRC and swamps sells an upgraded IDM for around $350 I think
Reply With Quote Quick reply to this message
  #10  
Old 07-20-2014, 09:25 PM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok thanks Ill see what i find.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors