Need help I can not figure this out! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-07-2014, 02:41 PM
Powerstroke.org Rookie
 

Join Date: Jul 2014
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need help I can not figure this out!

Alright y'all so I have an 03' Ford F250 super duty with the 7.3L turbo in it. A few weeks ago I was hauling cattle to the sale barn and made it there no problem. (65 miles) on my way out if the driveway went to get up to speed and she just wouldn't go past 40 mph. Started a quick ticking noise sounds like it was coming from the driver side just beyond the firewall. Then it started shuddering and spitting like I lost a cylinder or 2. Had it towed to the dealer spent 2500 bucks and didn't fix ****. They replaced the icp and 2 injectors and the wiring harness under the valve cover. I was able to make it home with the truck and we've had it since been trying to fix it and use it at the same time. Well now it's getting more frequent and it's really annoying. Sometimes I can drive it 200 miles without one issue. Other times I can drive it 20 miles and it'll loose power and just die on me. I'm outta ideas and need help. I've checked every fuse and every relay. They all function as they should. Oh and right before I start to lose power and it throws on the check engine light. But no codes. At least that I can pull with the scan tool we have. (Cheapy one) trip meter gives me codes of 9352,9201,d059. I'm at a loss on this one because I don't normally deal with electrical stuff. I was more a brakes steering and suspension tech. Not so much electrical diagnosis. Also I've got the tank out now because I thought I had a bad sending unit (fuel gauge isn't working) guys any questions you may have ask me. This things driving me up the wall and I don't know what else to do.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-07-2014, 03:09 PM
Premium Member
 

Join Date: Jan 2009
Location: Almost to the Muck but not quite
Posts: 1,389
Thanks: 23
Thanked 60 Times in 59 Posts
Feedback Score: 0 reviews
First i'd check fuel pressure. Have you ever changed the cps? (Cam Position Sensor). Its around 20$ at ford.

Then if all that checks out I'd be thinking IDM. (Injector Drive Module) its in the driver side fender well behind the plastic guard near the cab. When you take plastic piece loose pull it out the. Look up and the the right. You'll see the 10mm bolt for the plug.

Good Luck


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
The Following User Says Thank You to Ricemiester For This Useful Post:
Jayjay9002 (07-08-2014)
  #3  
Old 07-07-2014, 06:15 PM
Powerstroke.org Rookie
 

Join Date: Jul 2014
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes already replaced the CPS. IDM is on it's way should be here tomorrow. If that doesn't fix it what should I look at next? I'm out of ideas.
Reply With Quote Quick reply to this message
  #4  
Old 07-07-2014, 07:11 PM
Premium Member
 

Join Date: Jan 2009
Location: Almost to the Muck but not quite
Posts: 1,389
Thanks: 23
Thanked 60 Times in 59 Posts
Feedback Score: 0 reviews
I'd test fuel pressure next for sure.



Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #5  
Old 07-07-2014, 10:33 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Chico, California
Posts: 3,264
Thanks: 13
Thanked 83 Times in 79 Posts
Feedback Score: 0 reviews
ouch they charged you 2500 for 500 bucks worth of parts and like 3 hours labor wtf


did you ever check the ipr and see if the tin nut fell off or the firing is chafed.


also check the main wire harness were it goes over the valve cover, it can chafe through and cause issues as well.

running any sort of chip/or tuning?

and get a better reader that actually pulls codes. the codes might tell you whats wrong but you don't know if you can read them
Reply With Quote Quick reply to this message
The Following User Says Thank You to blue99stroker For This Useful Post:
Jayjay9002 (07-08-2014)
  #6  
Old 07-08-2014, 08:33 AM
Powerstroke.org Rookie
 

Join Date: Jul 2014
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No chip no tuner this is just the farm beater. Although it needs to run because it's cheaper to run this than the other truck. I have not checked the ipr but the shop said they checked the wiring and all that. Although now in not so sure how much I believe them. The IDM should be here today so I'll put that in and let y'all know once I get the tank back up.
Reply With Quote Quick reply to this message
  #7  
Old 07-09-2014, 01:54 PM
Powerstroke.org Rookie
 

Join Date: Jul 2014
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Alright y'all IDM just got put in made it 10 miles and she's doing the same thing although this time no check engine light. I don't have a fuel pressure gauge at the moment but I'm sure I can get one. I'm lost as to what to do.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors