Little work on the Tow Rig. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-04-2009, 05:41 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Frankfort, IL
Posts: 211
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Midwestern4x4 Send a message via Yahoo to Midwestern4x4
Little work on the Tow Rig.





About 3-4 Months ago I got myself a new tow rig. 99 F250 With around 195k on the ticker. I knew it had a slight oil leak but nothing to terrible so I never thought to do anything about it. About 2 months ago I had the cam sensor take a **** , and got the dealer to replace it under recall. About 3 week ago I pulled out of my driveway , and snapped the steering box sector shaft.










I got that fixed , and started to notice a power steering leak, and some more oil leaking. Last week I had the cam sensor go again , and my abs light is on , and I have no spedo. I still need to figure that out but I have other stuff on my plate first. I got some new Tires for it , and it looks a hella lot better than the bald ones on it did. Got some 315/75/16 Cooper STT's. They are great , and I am very happy with them. The next day ,
I wound up spending 7 hours at the Parking lot at Home Depot In Frankfort/ The eventual solution was pull k5 off trailer , and pull ford on trailer with k5.


Last edited by Midwestern4x4; 01-04-2009 at 05:47 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-04-2009, 05:44 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Frankfort, IL
Posts: 211
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Midwestern4x4 Send a message via Yahoo to Midwestern4x4
Well the oil leak got worse , and worse , and I lost 7-8 Quarts in a month so It was time to Fix that. It also doesn't like Cold weather so I wanted to look into that. Anyways the top of the engine is tore apart , and I am waiting on parts for all the seals. Replacing anything , and everything that will leak.

So Far -
Turbo Pedestal O ring set (With New Bolts)
High Pressure Oil Pump O ring set (With O ring for the Plug)
High Pressure Oil Seal (Pump to block)
High Pressure Oil Reservoir to block o ring.
Injection Pressure Regulator O ring
High Pressure Oil Rail Plug O rings.

- Glow Plug Relay , and I have 6 Bad Glow plugs so I am putting 8 Glow plug in it.

Hopefully that helps.. Well now I am just waiting on parts





Last edited by Midwestern4x4; 01-04-2009 at 05:48 PM.
Reply With Quote Quick reply to this message
  #3  
Old 01-04-2009, 06:36 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Mokena, IL
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews


yea these trucks arn't the lightests vehicles i dont think your trailer liked it too much
Reply With Quote Quick reply to this message
  #4  
Old 01-04-2009, 07:17 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Frankfort, IL
Posts: 211
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Midwestern4x4 Send a message via Yahoo to Midwestern4x4
Well 7k-7.5k on the trailer plus 1900lbs on the trailer it self..
Reply With Quote Quick reply to this message
  #5  
Old 01-04-2009, 07:23 PM
Viking Heavy Diesel

 

Join Date: Nov 2007
Location: 34'.6264 -98.4192
Posts: 20,700
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
WOW! I feel your pain though. Good luck with the fix. Good pics too!
Reply With Quote Quick reply to this message
  #6  
Old 01-04-2009, 08:20 PM
Banned

 

Join Date: Jul 2008
Location: Bryan/College Station/Tyler, TEXAS
Posts: 26,458
Thanks: 11
Thanked 9 Times in 8 Posts
Feedback Score: 1 reviews
u have 2 gpr?
Reply With Quote Quick reply to this message
  #7  
Old 01-05-2009, 02:59 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: Frankfort, IL
Posts: 211
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Midwestern4x4 Send a message via Yahoo to Midwestern4x4
Quote:
Originally Posted by bockhold View Post
u have 2 gpr?


One is an Intake Air Heater Solenoid.
Reply With Quote Quick reply to this message
  #8  
Old 01-05-2009, 06:39 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 40 Times in 9 Posts
Feedback Score: 0 reviews
The speedo problem is probably the VSS on the rear pumpkin, $30 and 10 min to fix. If it threw a code check them. Not sure why you tore the top of the engine apart, my bet is you simply had a bad O ring in the HPOP line. And what in the H*** are you doing to your turbo in that one pic near the bottom,lol!!!! Anyway hope you get her fixed up.

NCH
Reply With Quote Quick reply to this message
  #9  
Old 01-05-2009, 06:52 AM
Rob Rob is offline
Super Moderator


 

Join Date: Aug 2006
Location: Layton, Utah
Posts: 13,239
Thanks: 3
Thanked 7 Times in 4 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rob Send a message via MSN to Rob Send a message via Skype™ to Rob
Quote:
Originally Posted by NCHornet View Post
The speedo problem is probably the VSS on the rear pumpkin, $30 and 10 min to fix. If it threw a code check them. Not sure why you tore the top of the engine apart, my bet is you simply had a bad O ring in the HPOP line. And what in the H*** are you doing to your turbo in that one pic near the bottom,lol!!!! Anyway hope you get her fixed up.

NCH


hes givin it a kiss goodnight!!!
Reply With Quote Quick reply to this message
  #10  
Old 01-05-2009, 06:52 AM
Compression Ignition Addict
 

Join Date: Aug 2008
Posts: 3,540
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the no speedo and ABS problem. It was the VSS in the rear i could only find it at dealer. Nice pics
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:45 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors