HELP!! my 2000 7.3 excursion turns over but wont start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-27-2008, 03:08 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP!! my 2000 7.3 excursion turns over but wont start

it was running fine this morning went to work no problems at all when i went to leave work turns over very strong but wont start it's getting fuel and has new fuel filter
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-27-2008, 03:10 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: baltimore oh
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
did you check your cps
Reply With Quote Quick reply to this message
  #3  
Old 12-27-2008, 03:18 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes i had a spare one so i changed it just to make sure thanks
Reply With Quote Quick reply to this message
  #4  
Old 12-27-2008, 03:18 PM
Emergency Services
 

Join Date: May 2007
Location: Columbus, OH
Posts: 5,538
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to cchase
check the fuses under the dash, sometimes they can come lose and cause a no start.
Reply With Quote Quick reply to this message
  #5  
Old 12-27-2008, 03:20 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i checked them . but someone was saying something about the fuel bowl heater
Reply With Quote Quick reply to this message
  #6  
Old 12-27-2008, 03:27 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: baltimore oh
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yea check your #30 fuse it's your fuel bowl heater/pcm fues but if it's out you won't have a waite to start light
Reply With Quote Quick reply to this message
  #7  
Old 12-27-2008, 04:18 PM
Powerstroke.org Rookie
 

Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my light is working
Reply With Quote Quick reply to this message
  #8  
Old 12-27-2008, 08:27 PM
Compression Ignition Addict
 

Join Date: Jul 2006
Location: Covington Tennessee
Posts: 443
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its a 30 amp fuse under the hood. the one farthest fron the fender.
Reply With Quote Quick reply to this message
  #9  
Old 12-27-2008, 08:32 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: IN
Posts: 1,855
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
whats the temperature where your from? Bad glow plugs? harness?
Reply With Quote Quick reply to this message
  #10  
Old 12-28-2008, 06:49 AM
Powerstroke Junkie

 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 28 Times in 7 Posts
Feedback Score: 0 reviews
If you are sure it is getting plenty of fuel, unplug the ICP and see if it will start, if there is oil on the connector it is bad.

NCH
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:00 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors