PLEASE HELP!!! I THINK I BLEW MY TRUCK UP - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-26-2008, 07:33 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: san antonio, tx & long beach MS
Posts: 291
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to bignasty250
PLEASE HELP!!! I THINK I BLEW MY TRUCK UP

well, i guess i messed somethin up. iwas goin down the interstate today and a 6.0 tried to race me, i ended up racin him and we got up to about 110 so i let off so i wouldnt mess anything up. i started slowing down and the motor was runnin fine until i hit about 75 and it shut off, it wasnt knocking, running hot and it didnt lock up. i pulled to the side of the road and when i stoped it was pourin oil right where the motor and tranny couple, it was about 2 quarts that came out. i looked around the heads and there was no traces of oil or coolant around the gaskets but the was a little puddle on top of the motor and there was oil around the turbo. what could i have messed up??? please help me with this and also the motor will not start and it is not making any out of the ordinary noises.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-26-2008, 07:38 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: anderson
Posts: 221
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like you blowed and oil line off some where
Reply With Quote Quick reply to this message
  #3  
Old 12-26-2008, 07:54 PM
Compression Ignition Addict
 

Join Date: Feb 2008
Location: rockford oh
Posts: 1,305
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like a HP oil line to me. The hp pump is right on the front of the motor on top. I have seen the lines blow and then it goes back the valley and there is a drain hole where it will run out right where you are talking. No high press oil no start. The injectors don't have the oil to run the spool valves. I am no Tech so this is just my theroy. I have been wrong before. Get up on top of the motor on the driver side front is your high press pump. Look @ the lines off of it, may have blowed a o ring on one of them.
Reply With Quote Quick reply to this message
  #4  
Old 12-26-2008, 07:56 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2008
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does it crank? Try turning the motor with a 1/2 in breaker bar and socket on the crank pulley does it move?
Reply With Quote Quick reply to this message
  #5  
Old 12-26-2008, 08:39 PM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: san antonio, tx & long beach MS
Posts: 291
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to bignasty250
it turns over fine
Reply With Quote Quick reply to this message
  #6  
Old 12-26-2008, 08:46 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2008
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
so the starter works then.. sounds like dusty might be right i would check find out where that oil is from because it sounds right that if theres no oil up top in the hpop then it wont start....
Reply With Quote Quick reply to this message
  #7  
Old 12-26-2008, 09:02 PM
Rob Rob is offline
Super Moderator


 

Join Date: Aug 2006
Location: Layton, Utah
Posts: 13,239
Thanks: 3
Thanked 7 Times in 4 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rob Send a message via MSN to Rob Send a message via Skype™ to Rob
check those lines...
Reply With Quote Quick reply to this message
  #8  
Old 12-26-2008, 09:05 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Hadley, Michigan/Lima, Ohio
Posts: 3,067
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to thesmokinstroke02
deffinently a line. to much pressure. 7.3's dotn like 100+ lol
Reply With Quote Quick reply to this message
  #9  
Old 12-27-2008, 01:18 PM
Compression Ignition Addict
 

Join Date: Jun 2008
Location: Lebanon,TN
Posts: 1,141
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
what they all said it sounds like hpop line and isnt the hpop resavor about two courts?
Reply With Quote Quick reply to this message
  #10  
Old 12-27-2008, 02:19 PM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by 1badpsd View Post
what they all said it sounds like hpop line and isnt the hpop resavor about two courts?
1qt. in the res., 1qt. in each head.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors