No Power no dash - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-15-2006, 05:34 AM
Powerstroke.org Rookie
 

Join Date: Nov 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No Power no dash

My 03 7.3L F250 starts and runs but has no acceleration and no gauges or lights on the dash work. I think I checked every fuse I think with no luck any ideas on what may be causing this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-15-2006, 05:55 AM
Conservative and Proud


 

Join Date: Nov 2005
Location: Oregon
Posts: 14,472
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Did you check the fuses under the hood?
Reply With Quote Quick reply to this message
  #3  
Old 11-15-2006, 06:02 AM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
U still have a fuse blown, i dont remember which one but if i remember right its a 10Amp fuse and i know its in the fuse panel inside. The thing that is causing your problem though is the shift lever. The wires coming out of the shift lever that controll the overdrive button.....they fray on top of the steering column and short out......the shift lever needs replacement
Reply With Quote Quick reply to this message
  #4  
Old 11-15-2006, 06:04 AM
Premium Member
 

Join Date: Jan 2006
Location: florida
Posts: 1,893
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you know off the top of your head marc what the price is on the shift lever?
Reply With Quote Quick reply to this message
  #5  
Old 11-15-2006, 06:05 AM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nope....sorry brian
Reply With Quote Quick reply to this message
  #6  
Old 11-29-2006, 08:52 PM
Powerstroke.org Rookie
 

Join Date: Jul 2006
Location: federal way washington
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i just ordered a new shift lever because of the same problem (frayed wires) i had my od button giving me intermittent issues and after investigating i found my wires coming out of shift lever frayed. i was able to repair the wires for now but i did order a new shift lever. it was 54 dollars.
does anyone know if there is a fix for this so it dosent happen again?
would the wires shorting out cause shifting problems?
thanks in advance for your quick replys.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:00 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors