Steering shaft vibration after leveling??? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-22-2013, 10:54 AM Thread Starter
Compression Ignition Addict
HillbillyDeluxe39's Avatar
Join Date: Sep 2010
Location: San Marcos, Tx
Posts: 272
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Steering shaft vibration after leveling???

Installed a zone offroad leveling kit and had the truck aligned. A few weeks ago I started getting a vibration in the steering wheel. I can feel it and also hear it, extremely annoying. I've checked everything I can think of and it all looks ok. It only vibrates in gear, at idle/decel, with my foot on the break. I can sometimes feel the vibe in the brake pedal also.

Anyone experience anything like this before or have any ideas?

2000 F250 CCSB 4x4
6637, Tony Wildman Tunes, HPx, 6.0 IC, WW, 285/75R16 Hankook Dynapro AT's

HillbillyDeluxe39 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome