IPR proplems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-13-2008, 07:27 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2008
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
IPR proplems

I'm thinking I may be having problem with the IPR on my truck. At idle the engine rpm's are kind of eratic bouncing between 500 and 800 rpm's no check engine light. Should this type of problem set a code. thanks for looking
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-13-2008, 07:55 PM
Banned
 

Join Date: Feb 2008
Location: Northampton,MA
Posts: 792
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to blizzardwarrior7
Might be, but try unplugging your icp sensor, if that fixes it, you know your problem...My truck was doing the same thing, and by doing this I was able to determine it was the ICP...I just did the 10k mod, but used a 5.6K resistor and it fixed it.
Reply With Quote Quick reply to this message
  #3  
Old 07-13-2008, 08:14 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2008
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
by unpugging the ICP the the pcm use a default value so that the engine will still run. Can the IPR be removed and cleaned with my problem be intermitent I was thinking the IPR may be sticking, or does it have to be replaced. What are the common symtoms that indicate a failing IPR. May be a tech can chime in.
Reply With Quote Quick reply to this message
  #4  
Old 07-13-2008, 08:23 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
my mechanic says that my ICP sensor is probably bad as well. he said they are not too hard to change. just have to shell out 3 bills at the Fraud steelership to get a new one. rumor has it that the IH version will work.
Reply With Quote Quick reply to this message
  #5  
Old 07-13-2008, 08:28 PM
Banned
 

Join Date: Feb 2008
Location: Northampton,MA
Posts: 792
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to blizzardwarrior7
Im really betting its your ICP...If it is, one symptom of it would be that your truck runs ok and than the problem gets worse as your truck warms up...Might as well try unplugging it, it takes about 2.2 seconds. If this does it, try doing the 10k mod, Im serious, it fixed the problem on my truck..

And yes you can remove the IPR, I believe it is located on the High pressure oil reservoir in the middle of the engine....
Reply With Quote Quick reply to this message
  #6  
Old 07-13-2008, 08:45 PM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,087
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
THe IPR can be removed and cleaned... pretty easily.

Get a scanner on it and see if your ICP is bouncing around.
Reply With Quote Quick reply to this message
  #7  
Old 07-14-2008, 02:48 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2008
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
One problem is that I don't have access to a scanner. If I recall correctly my issues seem to have started after trying the 10k mod for less than 30 min. I did not like the way my truck ran with the 10k mod so I removed it.
Reply With Quote Quick reply to this message
  #8  
Old 07-14-2008, 07:27 PM
Banned
 

Join Date: Feb 2008
Location: Northampton,MA
Posts: 792
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to blizzardwarrior7
hmmm my only other suggestion would be to maybe try doing the 10k mod but try it with a 5.6k resistor, and than try it with an 18K resistor....I think they cost a buck for a pack of 5 at radioshack....Might fix it, thats what I would try first....Where are you located? If your close by you can borrow my scanner. Im in western MA
Reply With Quote Quick reply to this message
  #9  
Old 07-15-2008, 08:39 AM
International Threat
 

Join Date: May 2006
Location: Elkton, MD
Posts: 13,087
Thanks: 0
Thanked 6 Times in 4 Posts
Feedback Score: 1 reviews
Clean your ICP sensor.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:18 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors