Prodigy question? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 07-10-2008, 01:47 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Oct 2007
Location: Romeo, MI
Posts: 94
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Prodigy question?

I know this should be in the towing section but I need help ASAP. I picked up a rental horse trailer this afternoon to pick up the girlfriends new horse tomorrow morning. I hooked my Prodigy P3 brake controller up and all was well until we got down the road a ways. The unit flashes from the normal voltage screen to the "Trailer Disconnected" screen as I am driving. It is pretty intermittent and there is no set pattern to it. I thought it was due to the bumps in the road but I couldn't verify that as being the sole source of the problem either. I did notice a white wire dangling back by one of the wheels but until I get the tire off I can't tell where it goes. Does anyone know of some other cause to this problem that I can check when I get the tire off?

Thanks,
Mike

Early 99 F-250 Super Cab 4X4 Lariat
Red w/ Tan Leather Int.
148,XXX miles
Tymar Intake
4" Turbo back Magnflow Straight-piped exhaust
Unplugged Wastegate Line
285/75/16 Cooper S/T tires

Coming Soon
Custom Chip
MATREDGT is offline  
post #2 of 4 Old 07-10-2008, 01:55 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 14,898
Mentioned: 1 Post(s)
Tagged: 1 Thread(s)
Quoted: 203 Post(s)
Thanks: 74
Thanked 444 Times in 428 Posts
Garage
Feedback Score: 0 reviews
Sounds like you have a bad ground. Since it's a rental trailer, I would suspect the trailer. If there is a white wire hanging down, that may be your problem.

Can you call the rental place to see what they say? If you have the time, I'd have them fix it.


Owner | Operator: Darryl
My Truck: Ol' Guy Garage
Tow Toy: Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #3 of 4 Old 07-10-2008, 07:25 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Oct 2007
Location: Romeo, MI
Posts: 94
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
We have no time for the rental company to fix it for us unfortunately. I to thought it might be a ground issue and I suspected that every bump I hit was making the unit act up so I thought it would be a ground too. My first thought was that the manufacturer was so cheap they were trying to use the ball and coupler to make a ground path for the trailer but that wasn't the case. I messed with it a bit more but was never able to pull the wheel off because it got dark and storms were coming.

I am really suspecting that my problem might be in the pigtail that plugs into the trailer wiring plug that the factory supplied at the back of the truck. Does anyone have a part number for those pigtails? I believe this pigtail is the one that was in the glove box in the truck if the truck came from the factory with the trailer prep package. If someone had a part number or new of a place that sells them other than a dealer that would be great.

Thanks,
Mike

Early 99 F-250 Super Cab 4X4 Lariat
Red w/ Tan Leather Int.
148,XXX miles
Tymar Intake
4" Turbo back Magnflow Straight-piped exhaust
Unplugged Wastegate Line
285/75/16 Cooper S/T tires

Coming Soon
Custom Chip
MATREDGT is offline  
post #4 of 4 Old 07-11-2008, 06:16 AM
Compression Ignition Addict
 
Join Date: Nov 2007
Posts: 289
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same problem on my durango. But it was alomost like the plug was loose maybe? I would puch it in a bit more and it would be fine. I haven't had the problem with my X though so I know it wasn't the Prodigy.

Good Luck!

-DIY Tymar Intake
-ZooDad
-4" MBRP w/ 5" tip
-Guages
-HPX
-CCV mod
-New boots...
-Fuel Rail X
-DieselSite Transmission Filter
--W/ Guage and Flush valve
-Factory Tech Valve Body
-Stage 2 Snow Performance Water Meth
-AFE Blade Runner Intake Manifold
-TurboMaster WasteGate Control
-DieselSite Boost Relief Valve
-AIH Delete
-Garrett High Flow Outlet
-Garrett NON-EBPV Pedestal
-Plenum Inserts
-Torque Converter Lock Up Switch
cesspool is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome