Radio works intermittently - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-30-2013, 03:17 PM Thread Starter Rookie
Join Date: Nov 2006
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Radio works intermittently

Hi, I have a e99 that has intermittent problems with the aftermarket radio. The head unit is an Alpine and I have a Fosgate amp as well, the problem is that sometimes the radio works perfectly, other time the radio will work while you are waiting for the glow plugs and then when you start it the radio will not power up immediately, then it will slowly power up but will not function properly and has no volume. There is no pattern as to when it works or doesn't, it does not seem to be affected by rain or temperature as far as I can tell. Is this a symptom of something else or does it sound like an issue with the radio itself?

Last edited by rupp49er; 09-30-2013 at 03:22 PM.
rupp49er is offline  
Sponsored Links
post #2 of 3 Old 10-01-2013, 02:12 AM
Serving Our Country!
JSchuricht's Avatar
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,961
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 23 Times in 22 Posts
Feedback Score: 2 reviews
It could be the radio or a voltage issue. I would start by checking your grounds, both the stock truck ones and at the radio then check the voltage at the radio while it's acting up. I am guessing your seeing <11v which could be caused by a ground, bad connection or a bad battery.

JSchuricht is offline  
post #3 of 3 Old 10-01-2013, 02:14 AM
Compression Ignition Addict
GregsSD's Avatar
Join Date: Mar 2008
Location: Santa Rosa, CA
Posts: 1,359
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
It sounds like a radio problem, my Pioneer nav radio will do this sometimes when I start the truck.
When you first turn your key on to let the glow plugs warm up the radio starts to boot up, then when you turn your key to start the truck, the power to the radio is interrupted so the radio has to reboot, which can cause issues like this.

2005 F-250 CC/SB 4x4 medium wedgewood blue

5" lift, 5" Donahoe rear springs, 35x13.50 Extreme A/T's, 18x10 Ultra Predator wheels, 4.30 gears, Banks 4" exhaust, Airraid intake, SCT from Innovative, ARP headstuds, Bulletproof ficm, Scangauge II, Randy Ellis Design lightbar, Street Scene flares, Harpoon mod, Zoodad mod, LED 2010 taillights, dual color LED front turn signals, Pioneer avic-D3 with ipod and backup cams
GregsSD is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome