New to Forum- got a couple questions - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 08-07-2013, 10:38 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
New to Forum- got a couple questions

I've recently purchased an '03 with the 7.3 with 206K miles. Injectors and harness were replaced about a year ago. I installed an 8" lift, 20" wheels with 35" tires, an EDGE programmer, and a CAI. New tranny and torque converter immediately followed. Turbo back exhaust to be installed within the next few weeks.

1. Even with the 100hp program, truck seems like a turd compared to any of the other diesels I've owned-the 6.0 ford, the 5.9 dodge, and the LLY chevy. It's just slow. . .and the torque, in comparison, is disappointing pulling 12k lbs.

2. Without the EDGE, truck has a significant amount of black smoke. . .barely passed the visual part of the smog test. With the EDGE, the black smoke is ridiculous...I have to gently roll into the throttle, or there's a cloud.

3. I have to crank 4-5 seconds for it to start, warm or cold.

Mileage is right at 10. I'm guessing that all 3 of the above issues, as well as my lack of mileage, are related. I've searched this forum, without any luck or conclusion. . . anyone have any ideas on where I should start?? I appreciate the help- thanks!
bmjt7109 is offline  
post #2 of 10 Old 08-07-2013, 12:10 PM
Compression Ignition Addict
 
blue99stroker's Avatar
 
Join Date: Oct 2011
Location: Chico, California
Posts: 4,950
Thanks: 18
Thanked 210 Times in 201 Posts
Mentioned: 1 Post(s)
Quoted: 135 Post(s)
Feedback Score: 0 reviews
could be an oil related issue.

you could also have a boost leak.
do you have any gauges?

p.s. edge is not everybodys favorite choice. their tuning is lacking.

99.5 f250 7.3 4x4 258k
PHP Phoenix, S&B CAI, 4" TBE, Hpx, Stancor, RR Billet Wheel, AIH Delete, Autometer Gauges, Leveling kit, Transgo kit, Warn Hubs, Int'l Up-Pipes, RR IC Boots, Non-Ebpv Pedestal, High Flow Outlet, RR OCR, 08 Tow Mirrors.

Dad-2000 7.3 109k miles, Autometer Gauges, Superchips 1705, AIH Delete, 6637, 4" TBE, BD Billet Wheel, TruCool Max
blue99stroker is offline  
post #3 of 10 Old 08-07-2013, 12:33 PM
Super Moderator


 
SuperCrutyPS's Avatar
 
Join Date: Jul 2008
Location: Orangevale, CA
Posts: 15,070
Thanks: 79
Thanked 473 Times in 457 Posts
Mentioned: 2 Post(s)
Quoted: 231 Post(s)
Garage
Feedback Score: 0 reviews
Have you changed the oil / filters (oil and fuel)?
Is your turbo spinning well?
I agree with blue99stroker, you should have some type of monitoring to know what's going on. Gauges, Scangauge, or ???


Owner | Operator: Darryl
My Truck Garage: Ol' Guy
Tow Toy Garage : Pilgrim International 31RE3SLF5
United States Navy - IC2 - '76-'80
SuperCrutyPS is offline  
post #4 of 10 Old 08-07-2013, 12:44 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by blue99stroker View Post
could be an oil related issue.

you could also have a boost leak.
do you have any gauges?

p.s. edge is not everybodys favorite choice. their tuning is lacking.

Thanks for the response. . .the oil was changed right before I purchased the truck. I checked, it looks fine, and the level is where it should be. I've not changed the fuel filter- but will. Not sure if there's a boost leak- I looked, and don't see soot build-up at any of the connections. I'd agree, gauges are important- they are on the short list. I think I've got the EDGE sold. . .I've not heard great things.

I see you're from Chico. . . I miss living up there!!!

Thanks again. . . any and all input appreciated.
bmjt7109 is offline  
post #5 of 10 Old 08-07-2013, 12:46 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by SuperCrutyPS View Post
Have you changed the oil / filters (oil and fuel)?
Is your turbo spinning well?
I agree with blue99stroker, you should have some type of monitoring to know what's going on. Gauges, Scangauge, or ???

Seems to be. . . no boost gauge yet. Hopefully soon!
bmjt7109 is offline  
post #6 of 10 Old 08-07-2013, 04:33 PM
Member
 
Join Date: Jun 2013
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
I am also new to the forum, and diesels, and have found this forum very helpful. My truck is stock, but I have an Edge Insight that I use as gauges. Check your IPR and ICP - could be causing mileage/hard start/performance issues. Also check the EBP sensor and tube. I checked mine and it was plugged and the tube was cracked. I am hoping this solves my fuel economy issue. Also, build yourself a boost leak tester and check for leaks. I found several small ones that I hope will improve mileage and performance.
inspectorCSS is offline  
post #7 of 10 Old 08-07-2013, 05:45 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by inspectorCSS View Post
I am also new to the forum, and diesels, and have found this forum very helpful. My truck is stock, but I have an Edge Insight that I use as gauges. Check your IPR and ICP - could be causing mileage/hard start/performance issues. Also check the EBP sensor and tube. I checked mine and it was plugged and the tube was cracked. I am hoping this solves my fuel economy issue. Also, build yourself a boost leak tester and check for leaks. I found several small ones that I hope will improve mileage and performance.
Thanks. . .I've got some more research to do. . .everything I find on here is an acronym!!! IPR and ICP??? I watched the video on the EBP sensor and tube- learned what the EBP stood for- gotta learn the rest of the acronyms!!!!!
bmjt7109 is offline  
post #8 of 10 Old 08-08-2013, 03:12 AM
Compression Ignition Addict
 
blue99stroker's Avatar
 
Join Date: Oct 2011
Location: Chico, California
Posts: 4,950
Thanks: 18
Thanked 210 Times in 201 Posts
Mentioned: 1 Post(s)
Quoted: 135 Post(s)
Feedback Score: 0 reviews
ya their is a ton of acronyms lol
ipr is the injection pressure regulator, icp is injection control pressure. both of these sensors deal with the oil side of the injection system.

ya im a native chicoan. it is a great place to live. too bad you dont live here anymore i could give you some help.

99.5 f250 7.3 4x4 258k
PHP Phoenix, S&B CAI, 4" TBE, Hpx, Stancor, RR Billet Wheel, AIH Delete, Autometer Gauges, Leveling kit, Transgo kit, Warn Hubs, Int'l Up-Pipes, RR IC Boots, Non-Ebpv Pedestal, High Flow Outlet, RR OCR, 08 Tow Mirrors.

Dad-2000 7.3 109k miles, Autometer Gauges, Superchips 1705, AIH Delete, 6637, 4" TBE, BD Billet Wheel, TruCool Max
blue99stroker is offline  
post #9 of 10 Old 08-08-2013, 11:38 AM
Compression Ignition Addict
 
Join Date: Dec 2012
Location: Monroe, NC
Posts: 1,251
Thanks: 19
Thanked 39 Times in 16 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
[QUOTE=bmjt7109;6211698]1. Even with the 100hp program, truck seems like a turd compared to any of the other diesels I've owned-the 6.0 ford, the 5.9 dodge, and the LLY chevy. It's just slow. . .and the torque, in comparison, is disappointing pulling 12k lbs.

You cannot even compare the 7.3 to the 6.0 if you wanted speed. No way the 7.3 will ever be as fast as a 6.0 without thousands of dollars in mods. That being said the 7.3 is like a draft horse, slow and powerful. You have a very solid motor that will pretty much pull what ever you have. That being said do all the above have said, freshen everything up: Oil and filter change (t6), fuel filter change and air filter and she should be good to go IF there is no problems. Good luck with her.

99.5 F250 7.3 (Sold)
2006 F350 6.0 CC LB SRW FX4
Pro Comp 2.5 Leveling Kit
New Premium FICM from Ed
IPR GEN 2 EGR Delete w/ Up Pipe
Flo Pro 4" Turbo Back w/muffler
Blue Spring Mod
SCT Livewire ts
Ag Street Tune by Eric

Last edited by NCDeerHunter; 08-08-2013 at 11:42 AM.
NCDeerHunter is offline  
post #10 of 10 Old 08-08-2013, 06:51 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
[quote=NCDeerHunter;6224082]
Quote:
Originally Posted by bmjt7109 View Post
1. Even with the 100hp program, truck seems like a turd compared to any of the other diesels I've owned-the 6.0 ford, the 5.9 dodge, and the LLY chevy. It's just slow. . .and the torque, in comparison, is disappointing pulling 12k lbs.

You cannot even compare the 7.3 to the 6.0 if you wanted speed. No way the 7.3 will ever be as fast as a 6.0 without thousands of dollars in mods. That being said the 7.3 is like a draft horse, slow and powerful. You have a very solid motor that will pretty much pull what ever you have. That being said do all the above have said, freshen everything up: Oil and filter change (t6), fuel filter change and air filter and she should be good to go IF there is no problems. Good luck with her.
I'd agree with you there!!! Thousands to make the 7.3 a little faster, or thousands to make the 6.0 dependable. . .I had 2 different 6.0's, and both were problematic from the start. When they ran, they were fantastic. I heard great things about the 7.3, and mine has a significant amount of miles. I'll attack the recommended fixes, hopefully starting this weekend. My biggest concern is the amount of black smoke. . . seems to be wasting lots of fuel! Thanks a bunch for the input.
bmjt7109 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome