Turbo to intake spider seal - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-29-2008, 12:57 AM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,575
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo to intake spider seal

Is there an O-ring or anything that is supposed to go between the turbo and the intake spider? Iím not sure if I lost it during one of the many times I removed the intake/innercooler manifold. Does it just clamp on like the down pipe and up pipe collector or is there supposed to be a seal in there?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-29-2008, 02:57 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: frazeysburg ohio
Posts: 803
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine has an oring
Reply With Quote Quick reply to this message
  #3  
Old 03-29-2008, 02:58 AM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Wind Gap, Pa.
Posts: 212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah there is supposed to be one. Have to be careful when removing the intake tube. Look in your valley on the top of the motor, it's probably in there.
Reply With Quote Quick reply to this message
  #4  
Old 03-29-2008, 08:21 PM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,575
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
That may explain why with the factory turbo I got 30-32 psi boost and with the Dominator D-66 I ony get about 28 psi. Plus it also makes some funny air rushing noises, I gotta try to find that ring or buy another one.
Reply With Quote Quick reply to this message
  #5  
Old 03-30-2008, 03:00 AM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Wind Gap, Pa.
Posts: 212
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeap, sounds like the seal is missing. But don't understand how you still have 28psi. of boostThe seal may be on the old turbo you took off, check it if you still have it.
Reply With Quote Quick reply to this message
  #6  
Old 03-30-2008, 11:27 PM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,575
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Can't find the seal, I'll go by the Ford place in the morning and try to order another one. Thanks guys,
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:55 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors