5 AA'S ?????? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-13-2013, 12:43 PM
Member
 

Join Date: Sep 2008
Location: Baja, Mx in the Summer
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Jerryjust
5 AA'S ??????

Need a little help; I had installed a set of rebuilt injectors AD'S and they sent 5 AA"S and 3 AD'S and will not resend the right ones. My truck is a 2001 and require AD's; The funny thing it runs great and has never failed to not start. Also fuel use is just the same as before. The only thing is the service light stay on, I can erase it and it comes back on after two starts. Any Help out there.

Thanks in Advance Jerryjust

Last edited by Jerryjust; 06-16-2013 at 11:57 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-13-2013, 01:06 PM
Premium Member


 

Join Date: May 2010
Location: a base near you
Posts: 1,101
Thanks: 11
Thanked 20 Times in 18 Posts
Feedback Score: 1 reviews
Who sent you the injectors? Why wont they make it right?
Reply With Quote Quick reply to this message
  #3  
Old 06-16-2013, 11:53 AM
Member
 

Join Date: Sep 2008
Location: Baja, Mx in the Summer
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Jerryjust
5 AA'S?????

The place I purchased them from Was "Diesel Care & Performance Inc. in
Memphis, Tenn. WWW.Diesel Daddy.Com Bad Company. They said it took to long to notify them, I called 10 times and they gave me the run around.

Jerryjust
Reply With Quote Quick reply to this message
  #4  
Old 06-16-2013, 12:06 PM
Premium Member


 

Join Date: May 2010
Location: a base near you
Posts: 1,101
Thanks: 11
Thanked 20 Times in 18 Posts
Feedback Score: 1 reviews
was this a ebay deal?
Reply With Quote Quick reply to this message
  #5  
Old 06-16-2013, 09:00 PM
Serving Our Country!
 

Join Date: Aug 2007
Location: Manor, TX
Posts: 2,814
Thanks: 0
Thanked 11 Times in 10 Posts
Feedback Score: 2 reviews
It's not uncommon to reuse the solenoids from different injectors when building new ones. It's the guts of the injector that must be the same for everything to work correctly. As for the SES light, what codes are you seeing?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:14 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors