Help with bent bracket - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-03-2013, 04:45 AM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Location: SW Pennsylvania
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help with bent bracket

I replaced my exhaust back pressure sensor and accident bent the bracket out screws into. I bent it back and everything lined up fine. But I thought I noticed some sort of sealant behind the bracket plate.

Do I need to worry about breaking the seal behind this bracket and having problems, or is the bracket just bolted on with nothing behind it?

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-03-2013, 06:35 AM
Compression Ignition Addict
 

Join Date: Aug 2010
Posts: 1,764
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
not sure about sealant, but i had to finnesse the bracket as well, to align the tube/sensor
Reply With Quote Quick reply to this message
  #3  
Old 05-03-2013, 12:58 PM
Serving Our Country!
 

Join Date: Aug 2007
Location: Manor, TX
Posts: 2,786
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 2 reviews
Make sure you didn't bend the tube any, it's easy to break it if it has been on the truck for a while. The plate that the bracket is on is for the HPOP gear inspection/bolt, there is RTV on it but it's not pressurized and just gets oil splashed against it. I pulled mine several times without replacing the RTV and never had a leak. If you want to upgrade, Strictly Diesel has a cover that uses a oring and a new tube that reroutes the sensor away from the cover.
Reply With Quote Quick reply to this message
  #4  
Old 05-03-2013, 01:35 PM
Powerstroke.org Rookie
 

Join Date: Apr 2013
Location: SW Pennsylvania
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Great!

I bent it before i put the new tube on, so the tube is fine. The old tube, well it was in two pieces when I took it off!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:13 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors