7.3L mid range throttle lag ? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 04-25-2013, 06:40 AM Thread Starter
Powerstroke.org Rookie
 
TundraRat's Avatar
 
Join Date: Apr 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3L mid range throttle lag ?

I have a 2001 F350 with the 7.3L in it, I have started noticing mid range throttle lag. up to 1/4 throttle is good power also 3/4 and full throttle has good power no real lag, it's just starting to get going " from a red light" under easy acceleration 2/4s throttle I notice a bad lag in power ?
Anyone seen this and if so help. thanks
TundraRat is offline  
post #2 of 7 Old 04-25-2013, 07:22 AM Thread Starter
Powerstroke.org Rookie
 
TundraRat's Avatar
 
Join Date: Apr 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
May also be not shifting right in mid range, not sure seems like the motor hangs or bogs a bit then will shift later than it should..
This only happens at 2/4s throttle above or below 2/4s throttle everything runs awesome.
TundraRat is offline  
post #3 of 7 Old 04-25-2013, 06:19 PM Thread Starter
Powerstroke.org Rookie
 
TundraRat's Avatar
 
Join Date: Apr 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
anyone ?
TundraRat is offline  
post #4 of 7 Old 04-25-2013, 06:31 PM
Powerstroke.org Fanatic
 
russtwentyfour's Avatar
 
Join Date: Oct 2011
Location: Tyler
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Maybe a going bad tps sensor


E99 F350 Ext. cab Long bed, single wheel 2x4
Riff Raff 6637 intake, FRX and HPX,
Dieselsite boostfooler, factory tech valvebody, filter system,
Local custom trans build - BTS in near future,
Derale cooling pan and trans cooler,
Mbrp 4" turbo back
Ts 6 pos chip - TW tunes coming soon,
Guzzles hutch and harpoon mod with lift pump and racor filters
Ww2
Blank pedestal with moded exhaust port
Afe rear end cover
Callahan drilled and slotted rotors front and rear
russtwentyfour is offline  
post #5 of 7 Old 04-25-2013, 06:36 PM Thread Starter
Powerstroke.org Rookie
 
TundraRat's Avatar
 
Join Date: Apr 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by russtwentyfour View Post
Maybe a going bad tps sensor
I'll check that out. Thanks 4 the reply. going to get some tuner cleaner and spray the hell out of it.. would the TPS send a code ?

Last edited by TundraRat; 04-25-2013 at 06:40 PM.
TundraRat is offline  
post #6 of 7 Old 04-25-2013, 06:50 PM
Powerstroke.org Fanatic
 
russtwentyfour's Avatar
 
Join Date: Oct 2011
Location: Tyler
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No it won't send any codes or at least it didn't on mine, I took mine off and spayed electrical parts cleaner in the crack while working with screwdriver then sprayed wd 40 and worked a little. Has been great for almost a year now. Napa sells them also but not near the quality or price of oem.


E99 F350 Ext. cab Long bed, single wheel 2x4
Riff Raff 6637 intake, FRX and HPX,
Dieselsite boostfooler, factory tech valvebody, filter system,
Local custom trans build - BTS in near future,
Derale cooling pan and trans cooler,
Mbrp 4" turbo back
Ts 6 pos chip - TW tunes coming soon,
Guzzles hutch and harpoon mod with lift pump and racor filters
Ww2
Blank pedestal with moded exhaust port
Afe rear end cover
Callahan drilled and slotted rotors front and rear
russtwentyfour is offline  
post #7 of 7 Old 04-27-2013, 12:27 PM Thread Starter
Powerstroke.org Rookie
 
TundraRat's Avatar
 
Join Date: Apr 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Found the problem, it was air in the fuel system from what I resealed the hpop. It fixed itself.
TundraRat is offline  
Reply

Tags
mid range , throttle lag

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome