Starting to get a rough idle - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 04-11-2013, 11:12 AM Thread Starter
Premium Member
 
LSDRob's Avatar
 
Join Date: Aug 2012
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Starting to get a rough idle

Over the past 3 days I have noticed that the truck has developed a rough idle when coming to a red light, doesn't do it all the time just every now and then and happening more and more. It kind of sounds like a misfire but when rolling it runs like a top. I have pulled the plug on the IPR ( plug on drivers side head in the front kind of by the fuel bowl ) and that seems to smooth it out. Have checked the ECM for codes and there isn't anything stored in the computer, is the anything else that could be causing the issue?

Any and all help is appreciated.
Thanks in advance - Robert.

01 extended cab long box F-250 4x4 150,000 and still Rollin. Brand new 4r100 and ts 6 position chip with custom tunes, Garrett gtp38r turbo,Diamond eye 5" turbo back, RiffRaff FRx, RiffRaff HPx, 6637. 4" lift on 37x12.50xR17 with black addict xd series wheels. More to come soon!

LSDRob is offline  
post #2 of 4 Old 04-11-2013, 12:40 PM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
if that plug you pulled, had oil present, then yes, need to invest into a new sensor..(ICP).

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #3 of 4 Old 04-11-2013, 12:44 PM Thread Starter
Premium Member
 
LSDRob's Avatar
 
Join Date: Aug 2012
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
There is a tiny bit of oil present in the sensor. Would I be best going to ford for the sensor? Or would a shucks or napa be just a good? Part number? Hopefully can get it resolved before my 600 mile round trip this weekend.

01 extended cab long box F-250 4x4 150,000 and still Rollin. Brand new 4r100 and ts 6 position chip with custom tunes, Garrett gtp38r turbo,Diamond eye 5" turbo back, RiffRaff FRx, RiffRaff HPx, 6637. 4" lift on 37x12.50xR17 with black addict xd series wheels. More to come soon!

LSDRob is offline  
post #4 of 4 Old 04-11-2013, 12:57 PM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
97 03 Ford 7 3 Powerstroke Diesel ICP Sensor New | eBay

Or FORD for twice that much...

Dont settle for knockoffs/auto store icp or any of their sensors, for that matter. IF in a pinch, the CPS would be thee only sensor to buy from them places.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome