2000 F350 No Trailer Brake/Turn lights. - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 04-09-2013, 06:29 PM Thread Starter
Underpowered's Avatar
Join Date: Feb 2013
Location: Burlington, Ky
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 F350 No Trailer Brake/Turn lights.

towed a trailer for the first time since i got my power stroke and noticed I have Running lights, but no Brake/turn signals.

I checked both under hood fuses (7.5 amp) and both Ohmed out good. with the ignition on, both has 12v to them.

all wiring connections looked good at the plug end. By myself it was hard to to check for voltage at the plug itself however. My old meter does not react fast enough to check turn signal voltage changes. Gonna bring my meter home from work tomorrow to try again, but best i can tell it is not getting voltage to the plug.

My main concern however is if my brake contoler is working as i plan on towing about 12k this weekend and NEED it working, and plan on checking it as soon as i have some help to do so. I check wiring at the controller and i get voltage to it, and out of it, but once again can't check at the plug alone.

But as for the lights, i am stumped, without tracing individual wires back, i am not sure. are there any other relays/fuses specifically for the trailer setup?

'89 K5 Trail Rig--not at all stock
'98 Jeep ZJ DD-nearly stock
'00 F350 Tow Pig- bone stock.
Underpowered is offline  
Sponsored Links
post #2 of 2 Old 04-10-2013, 06:56 PM
Compression Ignition Addict
Joel's Avatar
Join Date: Oct 2008
Location: Abbotsford
Posts: 2,670
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 29
Thanked 122 Times in 110 Posts
Feedback Score: 0 reviews
Bump for this fellow.
I had the same problem last time i pulled a car, weird this is that it worked perfectly a few months before that.

Havent had time to check for myself yet.

PIS 175/80's, Van Turbo with EBPV, BD Billet Wheel
Lots of money spent at RiffRaff
Holley fuel pump, in tank mods, crappy riding leveling kit, DP-F6, 5 Gauges+Edge CS in dash, CB radio in Dash, over 100 goofy little mods
Still pretty slow, just less slow now.
Originally Posted by peixinho View Post
I love finally having my truck back... that 7.3 dog that I was driving was just not cutting it.
Joel is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome