turn signals don't work - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-11-2006, 06:33 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,760
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
turn signals don't work

Ok my hazards work but know turn signals I checked the fuse and replaced it just to make sure I had a good one there. I even replaced the one for the trailer turn signals as well but still no blinking light. Even the green arrow on the dash doesn't work any ideas what maybe worng.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-11-2006, 06:41 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
everything works perfect with the flashers?? green arrows and all exterior light are working??

try putting the turn signal switch to the brights and see if it works then.....play with it in as many positions as you can...flash to pass, etc while turning the blinkers on and see if you can get anything. Also, change the tilt of the column...see if anything comes back even if its just for a second...

Odds are if the flashers work and the turn signals dont, its a multifunction switch....(turn signal switch) if playing with the switch gets it to work even if only for an instant, definately replace it...if not, let us know the results of what you did...
Reply With Quote Quick reply to this message
  #3  
Old 09-11-2006, 09:43 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,760
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
trun signals don't work

Ok I tried all that already and no the green arrows do not work. The only time I get anything from the turn signal is with the hazards on. Then they work. I believe that would eliminate the relay. The reason why I say that is because they are the same circuit just different switch right. I got the wiring diagram and in the morning I am going to find out why I am not getting anything from the turn signal switch. But I believe you put me on the right track as it is the switch.
Reply With Quote Quick reply to this message
  #4  
Old 09-11-2006, 09:49 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,760
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
turn signal switch

If it is the switch how much would it cost to replace it I can install it myself unless I have to remove the steering wheel.
Reply With Quote Quick reply to this message
  #5  
Old 09-11-2006, 09:55 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,760
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
turn singals don't work

how much is a new switch
Reply With Quote Quick reply to this message
  #6  
Old 09-11-2006, 10:25 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
i think, but dont quote me on this, the switches are like 160-180 bucks.....

To replace it, you do not need to remove the steering wheel. You do need to take the split shroud of the steering column. To take the ignition cylender out, you turn it to run, and push the ball up that is visable once the lower half is off. Three phillips head screws hold the two halves together from the bottom. You also need to unscrew the tilt lever. It has a flat spot for a small crecent wrench right behind the fat portion....

Once the shroud is off, its just two connectors and three torx (t20 i think) screws......

Yes, the turn signal, brake, and hazards are all the same circuits (left turn, left hazard, and left brake are all the same wire), just a different command from the multifunction switch as to which wires get power, so since your hazards are working, thats why i think its probably the switch too. If you have access to the wiring diagrams, you should easily be able to test it though before you take it off after the shroud is off....
Reply With Quote Quick reply to this message
  #7  
Old 09-12-2006, 02:09 PM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,760
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
turn signals don't work

Ok aI got a new switch 97 dollars at the dealership. I put it in and it did nothing. So now I start doing other things I find out that when I ground out the turnsignals they work but they act like a bulb is blown. But all the lights work. I tried to find a relay but was unable to locate the relay box for my truck. The manual states it is behind the glove box for my year truck which is a 2002. I take the glove box out the only thing there is the blower motor. So where in the heck is that relay box. I here it clicking when the hazards are on. I hear clicking when I ground out the Turnsignals. But I am unable to locate it. I am starting to think that it is a bad ground but where is the grounding strap located. Any ideas.
Reply With Quote Quick reply to this message
  #8  
Old 09-12-2006, 06:47 PM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
the ground should be behind the drivers side kick panel if i remember right, and the relay should be in the fuse panel that is behind the panel that sits just in front of where your knees are on the drivers side...same place you were looking on the passanger side, but on the drivers side....
Reply With Quote Quick reply to this message
  #9  
Old 08-04-2007, 01:28 PM
Powerstroke.org Rookie
 

Join Date: Jul 2007
Location: Los Lunas
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by bigcountrysg View Post
Ok my hazards work but know turn signals I checked the fuse and replaced it just to make sure I had a good one there. I even replaced the one for the trailer turn signals as well but still no blinking light. Even the green arrow on the dash doesn't work any ideas what maybe worng.

My Poswerstroke has the same exact problem. I went ahead and replaced the Electronic Flasher relay (Relay 1 on fuse panel) still no luck at all. I didn't want to replace the switch since everything seemed to work fine on it. But I checked to see if it had juice on the fuse for both signals and there was nothing. Did yours have power there? Cause mine is doing everything yours is
except If I press on the brake and have a turn signal on at the same time, The opposite brake light that the turn signal isn't on will only light up.
Reply With Quote Quick reply to this message
  #10  
Old 08-06-2007, 01:00 PM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
theres a relay under the dash (its blue and square) its up behind the radio area best area i can giver ya from on here its bouta 10$ part that should fix it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:24 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors