slight chatter/clatter noise in front end - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-29-2008, 03:52 AM
Compression Ignition Addict
 

Join Date: Feb 2007
Posts: 1,726
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
slight chatter/clatter noise in front end

There seems to be a slight chattering noise coming from my front when you hit bumps or washboard roads . My drivers side hub is siezed up and im thinkin they are both either shot or close to it. Do bad hubs cause that noise or what else would it be? Im gonna get some warn premiums hubs if thats what it is. Anyways anyone know what is wrong here and a price idea to fix it?? thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-29-2008, 06:37 AM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Omaha Ne.
Posts: 168
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have no help but I have what I would guess is the same problem. My hubs are fine but my front end chatters. You would swear the ball joints were bad from the noise I get but they are fine. Your ball joints OK? Hope someone can help us.
Reply With Quote Quick reply to this message
  #3  
Old 01-29-2008, 07:29 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check your sway bar connections, if the bushings mounts are worn it can sound like a train wreck under there.
Reply With Quote Quick reply to this message
  #4  
Old 01-29-2008, 01:32 PM
Compression Ignition Addict
 

Join Date: Feb 2007
Posts: 1,726
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, I'll check them out. My ball joints should be fine both uppers and lowers were replaced 20k ago, but i guess who knows. thanks for the help
Reply With Quote Quick reply to this message
  #5  
Old 01-30-2008, 06:53 AM
Compression Ignition Addict
 

Join Date: Feb 2007
Posts: 1,726
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is there anything else this noise could be? and Im guessing those bushings in the sway bar mounts are easy to change??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:43 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors