need some help with my lift im installing. - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 01-27-2008, 12:58 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2007
Location: Boonville, IN
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
need some help with my lift im installing.

hi, im installing my own lift and ive ran into some problems as expected. i guess i need to extend my brake lines with this kit correct? its a 6.5" pro comp all spring lift. next, my shocks installed fine in the front but they are like 4 inches short in the back for some reason, do i loosen the lower shock bracket and rotate it up to get the mount right? instructions don't say anything about this. also, i have a pic below of how i think my rear spring all goes together, just curious if the aluminum block is for sure i piece i need. the way the instructions show it looks as it belongs there.do i need to get my front drive shaft lengthened, or does someone make a spacer to go on the flange or something to extend it.
on the front sway bar links, the instructions say to reuse the oem links, the ones in the kit are longer and would make the sway bar more parellel with the ground. im a newbie as this stuff and i just want my truck right when im done. also my truck in a 01 f250.


Thanks for any help guys!!!!




Rem870xj is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-27-2008, 01:13 PM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: Chicago
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That lift setup is asking for trouble.
Tony1784 is offline  
post #3 of 3 Old 01-27-2008, 01:33 PM
Compression Ignition Addict
 
99bigred's Avatar
 
Join Date: Jan 2008
Location: Covina CA
Posts: 601
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
looks like they sent you the wrong shocks. people dont like running 2 blocks like your setup but its the same on my dads truck and it seems fine. been on there for 60k miles and never had a problem offroad or towing a 11,000lb fith wheel.
good luck

early 99 f-350 7.3 6speed crew cab
banks exhaust, chip, big head, exhaust houseing
and wheel
Ford AIS intake
5.5" fabtech lift w/ 35x12.50/18's
99bigred is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome