engine light on/ nopower - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-27-2008, 08:54 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
engine light on/ nopower

i was pulling into a parking lot & went to pull into a stall
the truck started to run very rough & i also loss power
any help or ideas would be great
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-27-2008, 09:03 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Going to need more information? What year truck? Read the codes? 7.3 or 6.0, Recent fuel filter or oil change?
Reply With Quote Quick reply to this message
  #3  
Old 01-27-2008, 09:20 AM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: Santa Rosa, CA
Posts: 2,026
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if you have the 7.3, i am thinking the under valve cover electrical harness.
Reply With Quote Quick reply to this message
  #4  
Old 01-27-2008, 12:33 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
changed the fuel filter changed cps 7.3 2001
what am i look for under the valve covers
burnt wires
Reply With Quote Quick reply to this message
  #5  
Old 01-27-2008, 12:37 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Covina CA
Posts: 596
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
where the wires for the glow plugs and fuel injectors go through the valve cover there is a plug on the inside that is know for coming unplugged. ford makes a kit to keep it from hapening but we fixed ours with a zip tie and never had anymore trouble. have you scanned for codes?
Reply With Quote Quick reply to this message
  #6  
Old 01-27-2008, 12:39 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2001 7.3 do not have any code yet
Reply With Quote Quick reply to this message
  #7  
Old 01-27-2008, 12:40 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Covina CA
Posts: 596
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lights on but no codes?
Reply With Quote Quick reply to this message
  #8  
Old 01-27-2008, 12:40 PM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i checked those plugs they were good do not have acode reader
Reply With Quote Quick reply to this message
  #9  
Old 01-27-2008, 12:42 PM
Cynic
 

Join Date: Jun 2007
Location: Fort Worth, Texas
Posts: 11,179
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
You will need to scan for codes. Autozone and places like that usually won't be able to help you.
Reply With Quote Quick reply to this message
  #10  
Old 01-27-2008, 12:46 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Covina CA
Posts: 596
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you pulled both valve vovers and checked the inside plugs? hmmmm there went my guess. i think you have to get it scanned
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors