7.3 Mileage Issues - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 03-23-2013, 04:05 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2012
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 Mileage Issues

Howdy!

I just put a wonderful 7.3 on the road. It's a '99 F-250, reg cab, long bed. I have a 1500 pound welder generator mounted inside the box. I added two extra springs on each side in the back. She sits nice.

I'm having major fuel mileage issues. For 130-140 litres of diesel, I'm barely getting 400 kilometers per full tank of fuel.

Mind you, I deleted the muffler (four inch pipe all the way down), and installed an Air Raid cold air intake. The previous owner told me that I should be getting 800 kilometers plus in the winter, and a thousand kilometers plus in the summer months.

Something ain't right. I don't know what to do.

FYI, I just changed all glow plugs, glow plug relay, valve cover gaskets, and block heater.

If you dudes have any advice, I'm all ears.
What type of mileage should I be getting?

Thanks!
Welder_Dude is offline  
post #2 of 8 Old 03-23-2013, 06:08 PM
Member
 
patbraaap's Avatar
 
Join Date: Jul 2011
Posts: 60
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
woah.......thats about 7miles per gallon, i get about 15mpg with a 99 Extended cab long bed. So a little over 900 kilometers on 38 gallons of fuel (143liters) a little less in the winter like now.

E99' ECLB F250 7.3l PSD
4" MBRP Straight Pipe
DIY 6637 Intake
CCV Mod
285s
07' Front end swap
Tony Wildman 6 Pos. Chip
Gauges
X Codes
2" Mini Spring Pack
Bilsteins
T500 HPOP
08+ Mirrors
Hutch and Harpoon Mod
patbraaap is offline  
post #3 of 8 Old 03-23-2013, 06:47 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
Well, how do you drive it? How fast? How much idling? What RPMs do you run?



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #4 of 8 Old 03-23-2013, 07:06 PM
Member
 
Join Date: Nov 2011
Location: Princeton, Wisconsin
Posts: 40
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Flash and Flare Send a message via MSN to Flash and Flare
Clean your EBP tube and sensor, possibly replace the sensor. My mileage was in the single digits until I cleaned mine.
Flash and Flare is offline  
post #5 of 8 Old 03-24-2013, 10:03 AM
Compression Ignition Addict
 
chrgd2000's Avatar
 
Join Date: Jan 2012
Location: Leander TX
Posts: 202
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check for boost leaks, boots were killing my mpg

--7.3
chrgd2000 is offline  
post #6 of 8 Old 03-24-2013, 01:01 PM
Compression Ignition Addict
 
Joel's Avatar
 
Join Date: Oct 2008
Location: Abbotsford
Posts: 2,709
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 29
Thanked 125 Times in 113 Posts
Feedback Score: 0 reviews
WelderDude, where are you located?
Thats pretty bad mileage

PIS 175/80's, Van Turbo with EBPV, BD Billet Wheel
Lots of money spent at RiffRaff
Holley fuel pump, in tank mods, crappy riding leveling kit, DP-F6, 5 Gauges+Edge CS in dash, CB radio in Dash, over 100 goofy little mods
Still pretty slow, just less slow now.
Quote:
Originally Posted by peixinho View Post
I love finally having my truck back... that 7.3 dog that I was driving was just not cutting it.
Joel is offline  
post #7 of 8 Old 03-24-2013, 01:28 PM
Powerstroke.org Rookie
 
Join Date: Mar 2013
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm getting 16.5 in a sclb with a 4 inch lift and that's letting it run for 5-10 min in morning before I leave,avg 30 mile trip to work or store.
Diesel lineman is offline  
post #8 of 8 Old 03-24-2013, 01:41 PM
Compression Ignition Addict
 
Zaairman's Avatar
 
Join Date: Apr 2007
Location: Wright City, MO
Posts: 3,030
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 7
Thanked 18 Times in 18 Posts
Feedback Score: 1 reviews
Your mileage is about half of what it should be... I think you have a massive boost leak somewhere.

Zach
2000/2006ish Ford F-250 Larryette 7.3 Powerstroke 4x4
5" Sewer Pipe Exhaust (video clip), DIY 6637 Intake, Wicked Wheel'd, De-foiled, Missing EBPV, Edge Juice with Attitude, Few leaves added here and there, 35" BFGs, 16x10 Eagle Alloys, Alpine W200

SLAPS Member #153
Zaairman is offline  
Reply

Tags
7.3 fuel mileage issues

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome