Service Engine Code - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-12-2008, 09:44 AM Thread Starter
Join Date: Oct 2007
Location: DE-MD-PA (on the state line)
Posts: 70
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Service Engine Code

I got a code that reads.."#7 Cylinder Glow Plug Circuit" -- Truck (2000 Excursion 7.3) is smoky when starting. Any advice?

2000 Excursion 7.3 psd
80,000 Miles
PowerSlot Cryo Rotors + Hawk Pads
Edelbrock Performer IAS Shocks
Diamond Eye 4" Turbo back exhaust
DP Tuner F6 chip with 60HP tow, 80HP Econ and Decel Tunes
Boost, EGT and Trans Temp gauges on pillar
K&N air filter in stock system
Pull Rite towing system
6.0 Trans Cooler
redoil is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome