Intake system clogged? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-09-2013, 06:52 PM Thread Starter
khl
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Intake system clogged?

99 F350 7.3 The check valve? on the side of the intake air box pegs to "replace filter" and its yellow inside. I push button to reset it but it just says replace filter once I go driving again.

I put in a Fram CA9676 filter (severe duty) but it still does it. Is the indicator just bad, wrong filter or could there be something else wrong?
khl is offline  
post #2 of 5 Old 02-09-2013, 07:41 PM
Compression Ignition Addict
 
Join Date: Mar 2011
Posts: 988
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 0
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
Check the upstream air path and see if something before the filter is plugged.
ttyR2 is offline  
post #3 of 5 Old 03-26-2013, 03:42 PM Thread Starter
khl
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ttyR2 View Post
Check the upstream air path and see if something before the filter is plugged.
I checked it (runs to front grille area) To check it I took the whole pipe off from air filter housing to grille. No clog but I left it off, check valve says filter is good/no clog now. Been this way for 2 weeks. Odd...
khl is offline  
post #4 of 5 Old 03-26-2013, 03:44 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
Any tuner/chip? Pulling huge loads?



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
post #5 of 5 Old 03-26-2013, 05:11 PM Thread Starter
khl
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jesilvas View Post
Any tuner/chip? Pulling huge loads?
Stock. Just pull around trailer/Bobcat. Since removal of the pipe from airbox to grille, check valve stays in green
khl is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome