Loud creaking/rubbing noise in front end - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-28-2007, 01:32 PM
Member
 

Join Date: Oct 2007
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Loud creaking/rubbing noise in front end

My 01 PSD blew the powersteering hose right after I got it. It drenched the entire engine compartment and front underside of my truck with fluid. I fixed the hose and washed everything down as best as possible with a hose. Not a high pressure just a garden hose. I used some diluted simple green to help some areas, mainly on the painted surfaces.

A few days later I noticed a loud noise squeek/metal rubbing noise from the front of the truck. It sounds like it is coming from the front drivers side. It happens while going over a bump at low speed. Like a speed bump in a parking lot or the entry to my driveway. I have taken it in for an oil change and mentioned it, they said they lubed it real well. I have also had the front end aligned and they said they didnt see anything wrong.

I know sounds are hard to describe but it really soungd like an old rusty metal spring. I have tried to spray some penetrating oil on a few areas to try to see if the sound changed or stopped and no luck.

Anyone have any good ideason what to look for?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-28-2007, 01:38 PM
Premium Member
 

Join Date: Feb 2007
Location: Wisconsin
Posts: 1,366
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Look at all your bushings, check for shiny spots around the bushings indicating looseness
Reply With Quote Quick reply to this message
  #3  
Old 11-28-2007, 03:54 PM
Powerstroke Techie


 

Join Date: Jun 2007
Location: Huntsville/Arab alabama
Posts: 3,575
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine was doing that when I bought it, the plastic bushing plates between the ends of the leaf springs were worn out. If I remember right they were relatively cheap and easy to replace. here is a pic Shutterfly | Slideshow

Last edited by alabamafrog; 11-28-2007 at 03:59 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:18 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors