Hopefully this can help in trouble shooting - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-23-2007, 09:06 PM Thread Starter
Join Date: Oct 2007
Posts: 33
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hopefully this can help in trouble shooting

I have 99 F-350 7.3, with 150,000 miles. About a month ago I had a "crank but no start problem". It did this whether the engine was cold or hot. I was able to get get the engine to fire at the time on Ether(completly the wrong thing to use, but I had to get to and from work) or WD-40. I made the best judgement call and determined that engine wasn't getting fuel during start up. I first replaced the ICP sensor(Injection Control Pressure) then 3 days later the IPR sensor(Injection Pressure Regulator) and neither sensor worked.These sensors totaled about 300$ combined. Then proceded to take the truck to the dealer,and the technician determined that I had worn or cracked injector o-rings. He was correct and was also very nice and answered all my questions(River View Ford in Montgomery Illinios).He also said this was the third update for these injector o-rings.I 've now ran the truck over a thousand miles with no problems.Hopefully this can aid someone in the trouble shooting department and save a little money. -Trevor
Powered by International is offline  
Sponsored Links
post #2 of 2 Old 11-24-2007, 05:04 AM
Powerstroke Junkie

NCHornet's Avatar
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 47 Times in 10 Posts
Feedback Score: 0 reviews
Thanks for the report. Stories like yours is why I believe is proper troubleshooting and not just throwing parts at a problem. A $20 oil analysis would have showed what the problem was long before it became a no-start situation. I try and do one every other oil change, you wouldn't believe what they can tell you from a small sample of oil. But I am glad you got it running!!

Proud Father of USAF Airman

2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4


Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome