Hopefully this can help in trouble shooting - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-23-2007, 08:06 PM
Member
 

Join Date: Oct 2007
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hopefully this can help in trouble shooting

I have 99 F-350 7.3, with 150,000 miles. About a month ago I had a "crank but no start problem". It did this whether the engine was cold or hot. I was able to get get the engine to fire at the time on Ether(completly the wrong thing to use, but I had to get to and from work) or WD-40. I made the best judgement call and determined that engine wasn't getting fuel during start up. I first replaced the ICP sensor(Injection Control Pressure) then 3 days later the IPR sensor(Injection Pressure Regulator) and neither sensor worked.These sensors totaled about 300$ combined. Then proceded to take the truck to the dealer,and the technician determined that I had worn or cracked injector o-rings. He was correct and was also very nice and answered all my questions(River View Ford in Montgomery Illinios).He also said this was the third update for these injector o-rings.I 've now ran the truck over a thousand miles with no problems.Hopefully this can aid someone in the trouble shooting department and save a little money. -Trevor
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-24-2007, 04:04 AM
Powerstroke Junkie


 

Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,309
Thanks: 0
Thanked 34 Times in 9 Posts
Feedback Score: 0 reviews
Thanks for the report. Stories like yours is why I believe is proper troubleshooting and not just throwing parts at a problem. A $20 oil analysis would have showed what the problem was long before it became a no-start situation. I try and do one every other oil change, you wouldn't believe what they can tell you from a small sample of oil. But I am glad you got it running!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:46 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors