7.3 runs rough after idling fine - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-12-2013, 11:39 AM Thread Starter
Powerstroke.org Rookie
Join Date: Oct 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3 runs rough after idling fine

I have a 99.5 f350 srw with the 7.3, I started the truck the other day to let it warm up and when I came back out a few minutes later it sounded terrible, It was knocking rather bad, I shut off the truck and started it again, it ran fine for a few minutes then when I went to drive it after only a couple hundred feet, It started knocking, rpm's dropped super low and it had absolutely no power. I'm really stumped. I changed the fuel filter, unplugged the icp sensor, neither has helped. anybody have any ideas?
Sam_is_White is offline  
Sponsored Links

7.3 diesel, knocking, rough idle

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome