2001 f350 7.3 Wont start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-11-2013, 06:12 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2001 f350 7.3 Wont start

2001 f350 7.3 power stroke, lariat 285,000 miles. 4" lift, 35/12.5/r20, 5" turbo back exhaust, cold air intake, newly rebuilt turbo and injectors, and new glow plugs. WON'T START!! I have done a lot already and have kept it going by reading these forums but now I'm stumped.

Wouldn't start. Found starter solenoid cap was completely melted off. took back along with positive cable and replaced under warranty no charge. got started with jumping ran took off both positive cables to check alternator, died immediately. had to rejump got running went into to eat dinner let it warm up bout 35-45 min went back out and truck was not running. tried to turn key nothing tried to jump again and started clicking. clicking i believe is the glow plug relay. it is the relay closest to the turbo. Won't start, lights dim when relay clicks and when turn the key the starter just clicks.

Anybody whats know whats wrong with my truck? Thanks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-11-2013, 06:45 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2012
Posts: 149
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Grounding issue? I'd take the time to clean all grounds to the chassis. Unlikely but can't hurt. I'd also check voltage.
Reply With Quote Quick reply to this message
  #3  
Old 01-11-2013, 07:49 PM
Compression Ignition Addict
 

Join Date: Apr 2012
Posts: 857
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
If you pull the battery cables and it dies; that right there tells me that your alt is not charging . Sounds to me that you need an alt. Since your batteries are drained and alt is not charging; your truck can only run for so long off the dead batteries.

Get the truck started and put a volt meter on the battery. If its not reading 13+volts, its your alt for sure, but I guarantee it is the alt

Last edited by INFRNL; 01-11-2013 at 07:53 PM.
Reply With Quote Quick reply to this message
  #4  
Old 01-12-2013, 10:06 AM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
New alternator fixed the problem...Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors