My truck won't turn over! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-23-2012, 02:27 PM
Powerstroke.org Rookie
 

Join Date: Oct 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My truck won't turn over!

Okay I have a 2000 7.3 powerstroke with a dp tuner, drove the truck 2 days ago ran fine nothing was wrong with it, went to start it up yesterday and it won't turn over, plugged it in over night and still nothing, changed the cam sensor and glow plug relay, and changed the oil, it's getting fuel and cracks just won't turn overr. Thoughts??


Sent from my iPhone using AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-23-2012, 03:50 PM
Serving Our Country!
 

Join Date: Jul 2010
Location: Indiana
Posts: 411
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
tuner or chip? actually regardless of which put it back to stock (if you have a tuner) remove the chip from the pcm then try and start it, if it starts theres your problem.
Reply With Quote Quick reply to this message
  #3  
Old 12-23-2012, 11:21 PM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 3,543
Thanks: 175
Thanked 43 Times in 43 Posts
Feedback Score: 1 reviews
Bad starter ground? Did you try and jump the solenoid with channel lock pliers? When u charged it up, what voltage was the meter reading before you pulled the cables?
Reply With Quote Quick reply to this message
  #4  
Old 12-24-2012, 05:26 AM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: Too close to snookie
Posts: 3,111
Thanks: 20
Thanked 38 Times in 23 Posts
Feedback Score: 0 reviews
So it is cranking or it isn't?


Sent from my iPhone using AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #5  
Old 12-25-2012, 05:05 PM
LEARNING AS I GO


 

Join Date: Feb 2011
Location: Clever, Missouri
Posts: 206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same problem had it towed to ford at they said it was the ICM so replaced it and started just fine
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:08 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors