water pump/cooling problems - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 12-19-2012, 01:39 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
water pump/cooling problems

Hey guys Im new here but I am having a problem I cannot figure out! I have a 2001 f250 super duty pickup. I just replaced my waterpump, belt, both hoses,thermostat,sending unit. Everything was working fine but pump was leaking. Now for the problem, I am not getting any circulation thru the cooling system and the temp gauge will not move off of cold. I have at this time replaced the thermostat twice, the sending unit twice, I put a paper clip in the end of the sending unit plug and the gauge went to hot so that is working. the truck has idled several differant times for about an hour each time and the heater blows hot air but the degass tank is cold and no pressure at the rad cap. Any ideas?
scott959 is offline  
post #2 of 2 Old 12-20-2012, 07:09 PM
Compression Ignition Addict
 
Join Date: Mar 2011
Posts: 996
Thanks: 0
Thanked 9 Times in 8 Posts
Mentioned: 0 Post(s)
Quoted: 12 Post(s)
Feedback Score: 0 reviews
Thermostat in upside-down? Spring side should point towards the block.
ttyR2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome