Anyone have trouble with TW's customer service? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-03-2012, 05:31 PM
Member
 

Join Date: Feb 2007
Location: Bardstown,ky
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone have trouble with TW's customer service?

I was just wandering if anyone else has had problems with Tony Wildmans customer service??I ordered a chip about a month ago and recieved it but it only works right on a couple of settings.I have called numerous times and left messages and also sent a few emails all with no response over the past couple of weeks!I basiclly have a chip that doesn't do me any good.Maybe he has a good reason,I never had that problem before.Just curious..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-03-2012, 05:56 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Southern Michigan
Posts: 1,079
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Well I don't want to bad mouth anyone so ill just say YES, I had an issue similar to yours. After close to a year of sending the chip back and fourth and waiting to hear back I got my money back.

Good luck. Ill be using PHP soon
Reply With Quote Quick reply to this message
  #3  
Old 12-03-2012, 06:18 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,079
Thanks: 0
Thanked 14 Times in 14 Posts
Feedback Score: 0 reviews
I will say he part times tuning, and I know his daughter had medical issues. Check the Morgan Wildman thread.
But, it is still a business.
Just trying to clarify things.

I made my Samsung SGH-I997 send this.
Reply With Quote Quick reply to this message
  #4  
Old 12-03-2012, 06:24 PM
Member
 

Join Date: Feb 2007
Location: Bardstown,ky
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I knew that he had some medical issues in his family.I dont want anyone to think that I am on here to bash Tony and his busuiness,I just would like some answers to my problems.I had great luck with my OBS chip that I had got from him.Maybe I will hear something soon(I hope)
Reply With Quote Quick reply to this message
  #5  
Old 12-03-2012, 06:54 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,079
Thanks: 0
Thanked 14 Times in 14 Posts
Feedback Score: 0 reviews
I understand, and me too

I made my Samsung SGH-I997 send this.
Reply With Quote Quick reply to this message
  #6  
Old 12-04-2012, 03:16 PM
Powerstroke.org Rookie
 

Join Date: Jan 2009
Location: Brainerd MN
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Try talking with Cary, at CT Performance. He is a vendor on the forums and I know he sells Wildman tunes. Not saying he can help but it's worth a shot.
Reply With Quote Quick reply to this message
  #7  
Old 12-04-2012, 06:09 PM
Member
 

Join Date: Feb 2007
Location: Bardstown,ky
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tony just sent me an email to let me know that he had issues with his daughter and appologized for the delay.He assured me that he would make it right or issue me a refund.I just told him to take care of family first and we will take care of my problems when he is up to it.I cant imagine being in his position and trying to concentrate on work!
Reply With Quote Quick reply to this message
  #8  
Old 12-04-2012, 06:22 PM
Member
 

Join Date: Apr 2010
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Having exact same issues. Just sent my chip back for the 2nd time due to it not working correctly. (cuts out shifting positions, transmission not working smoothly)

I know he is having family issues and in the end that is more important than making my truck quick.

I have faith he will make it right tho.
Reply With Quote Quick reply to this message
  #9  
Old 12-05-2012, 09:22 AM
Compression Ignition Addict
 

Join Date: Apr 2008
Location: Wellington Nevada
Posts: 8,580
Thanks: 1
Thanked 33 Times in 33 Posts
Feedback Score: 5 reviews
Check your pcm..did you over clean it?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors