Electrical issue - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-24-2012, 05:42 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Electrical issue

Hi, I have a 03 7.3. I Have 12.5 volts at the batteries and power to starter. Donot have any power to cab. Does the power to the cab route through the starter or is there a fusable link or relay to power the cab directly from the battery? Missing something somewhere just need a litttle direction. Thanks.
moewsman1066 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-24-2012, 07:48 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 6,417
Thanks: 7
Thanked 273 Times in 262 Posts
Mentioned: 7 Post(s)
Quoted: 119 Post(s)
Feedback Score: 3 reviews
There's a, problematic, fuseable link connection in the later trucks that will do that. Have a look at this thread -> POTENTIAL ELECTRICAL CORROSION if your truck is like mine......
NoRalPh is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome