fuel pump fuse on 2001 7.3l - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 10-27-2012, 03:35 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jan 2012
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fuel pump fuse on 2001 7.3l

Every time i go over any holes or bumps my truck shuts off , it burns the fuel pump fuse, the first time it burned any fuse i putted on and after a few hours i put one fuse and it worked fine, the second time went over speed bumps and it burned it replaced it once and no problem, but today went over some holes and it burned like 10 fuses, we unploged the pump but still burning the fuses and after 6 hours we put a fuse and it worked fine, can anyone please help me solve this problem and thank you so much.
josean4700 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome