Two piece turbo - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 Old 10-21-2012, 09:57 AM Thread Starter
Member
 
mfd620's Avatar
 
Join Date: Aug 2011
Location: globe/miami
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Two piece turbo

Well i have been losing boost for a couple weeks now. When i removed the turbo i was only get 16 psi on 120 tune. This is what i found.

Sent from my VS920 4G using AutoGuide App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1350838584423.jpg
Views:	175
Size:	35.0 KB
ID:	44589   Click image for larger version

Name:	uploadfromtaptalk1350838599772.jpg
Views:	180
Size:	31.9 KB
ID:	44590   Click image for larger version

Name:	uploadfromtaptalk1350838616911.jpg
Views:	181
Size:	85.6 KB
ID:	44591   Click image for larger version

Name:	uploadfromtaptalk1350838634657.jpg
Views:	155
Size:	84.1 KB
ID:	44592   Click image for larger version

Name:	uploadfromtaptalk1350838647912.jpg
Views:	156
Size:	78.4 KB
ID:	44593  

mfd620 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 10-21-2012, 09:59 AM Thread Starter
Member
 
mfd620's Avatar
 
Join Date: Aug 2011
Location: globe/miami
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It came off the truck like in the pictures. I have no clue how I had any boost.

Sent from my VS920 4G using AutoGuide App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1350838673729.jpg
Views:	83
Size:	35.5 KB
ID:	44594  
mfd620 is offline  
post #3 of 15 Old 10-21-2012, 10:46 AM
Serving Our Country!
 
7.3HeavyHauler's Avatar
 
Join Date: Jul 2010
Location: Indiana
Posts: 411
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
wow thats wow can't even think of a word for that, hope you find out what caused that.

My avatar is my goal for the 7.3
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
7.3HeavyHauler is offline  
post #4 of 15 Old 10-21-2012, 10:54 AM
Premium Member
 
MyTractorsSexy's Avatar
 
Join Date: Sep 2011
Location: St.Louis Mo
Posts: 1,622
Thanks: 1
Thanked 10 Times in 9 Posts
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Feedback Score: 2 reviews
what intake are you using?

07 F250-SOLD

2011 Black CC SB Lariat F250, 2015 Retrofit, MPD IC Piping, H&S Mini Maxx, 5"Flo-pro Exhaust, Sininster Egr Delete, Recon Smoked Lights, No Limit S2 Intake, 20% Tint, BDS 8" 4-Link Lift w/ Fox Shocks & Dual Steering Stabilizer, Toyo MT's, 2-Piece Fuel Maverick 22x12 Wheels, PTM Grille Surround, T REX X-Metal Grille, super bright leds 6500K heads and fogs, kenwood double din, 4 hertz 210W door speakers 2 JL TW3 10s kenwood amps.

Thanks to bigblack for selling me his truck
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MyTractorsSexy is offline  
post #5 of 15 Old 10-21-2012, 11:22 AM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Exhaust wheel looks melted

I made my Samsung SGH-I997 send this.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jesilvas is offline  
post #6 of 15 Old 10-21-2012, 11:26 AM
Compression Ignition Addict
 
Joel's Avatar
 
Join Date: Oct 2008
Location: Abbotsford
Posts: 2,730
Thanks: 29
Thanked 127 Times in 115 Posts
Mentioned: 2 Post(s)
Quoted: 10 Post(s)
Feedback Score: 0 reviews
It was a fairly common problem for the bolts to rattle loose. Thats what happened to yours right?

When i took my turbo out recently on bolt was absent and the others were very loose too

PIS 230/80's, Van Turbo with EBPV, BD Billet Wheel
Lots of money spent at RiffRaff
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Dual SD fuel pumps, in tank mods, CNC Fab bowl retain kit. SDK Tunes. Isspro.
Still pretty slow, just less slow now.
Quote:
Originally Posted by peixinho View Post
I love finally having my truck back... that 7.3 dog that I was driving was just not cutting it.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Joel is offline  
post #7 of 15 Old 10-21-2012, 11:34 AM Thread Starter
Member
 
mfd620's Avatar
 
Join Date: Aug 2011
Location: globe/miami
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes the bolts rattled out of it. When i bought the truck the top bolt where already gone. It took a year for the bottoms to fall out. Was all good cuz i had a spare turbo waiting to be put in.

Sent from my VS920 4G using AutoGuide App
mfd620 is offline  
post #8 of 15 Old 10-21-2012, 05:07 PM
Compression Ignition Addict
 
dieselcrawler's Avatar
 
Join Date: Aug 2007
Location: New Martinsville, West Virginia
Posts: 3,273
Thanks: 0
Thanked 54 Times in 52 Posts
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Feedback Score: 0 reviews
I think you might be ready for a wicked wheel!!! *grin*

All I can say is "WOW"... hate to start thinking about where all the peices that got chewed off went... hope you cleaned out the intercooler, in hopes that any of them got stuck there before going thru the motor.

Greg

'99 E350 DRW Stahl 11' util box van, 7.3 PSD, stock. 138k SOLD

'00 F350 extcab, 9' utility bed, dually 228k


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
E'99 F250 extcab, S/Bed 211k. Sidelined due to motor issues.

'00 Excursion Limited, 7.3PSD 294k

'84 Chevy K-30, 6.2L TD, woods/trail beater. 141k

Semper Paratus
dieselcrawler is offline  
post #9 of 15 Old 10-21-2012, 05:08 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Intake? That's the exhaust.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jesilvas is offline  
post #10 of 15 Old 10-21-2012, 05:32 PM Thread Starter
Member
 
mfd620's Avatar
 
Join Date: Aug 2011
Location: globe/miami
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes that was the exhaust side.

Sent from my VS920 4G using AutoGuide App
mfd620 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome