Dead Again - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 08-22-2012, 02:11 PM Thread Starter
Member
 
fordguy2's Avatar
 
Join Date: Sep 2011
Posts: 33
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Dead Again

So for the third time this summer my truck has been dead when I went out to start it. The other two times have had me replacing my alternator. So now is my question, what could be causing my batteries not to charge since I have put 2 new alternators in already? Something shorting out? Radio being on causes it to drain? Im lost and have no clue where to start and all the auto parts stores will do is just put in another alternator. If anyone has any ideas of what I can check please let me know.
fordguy2 is offline  
post #2 of 8 Old 08-22-2012, 08:36 PM
Powerstroke.org Fanatic
 
a.alford's Avatar
 
Join Date: Jul 2012
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
how old are the batteries? do you use the trucks electronics alot when its not running?

'00 F-350 7.3 6637 mod with php tunes.
a.alford is offline  
post #3 of 8 Old 08-23-2012, 08:22 AM Thread Starter
Member
 
fordguy2's Avatar
 
Join Date: Sep 2011
Posts: 33
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Batteries are about a month old with the first alternator then put in the second one. I use the radio all the time but how would that cause anything cause it never bothered it before?
fordguy2 is offline  
post #4 of 8 Old 08-23-2012, 08:56 AM
Compression Ignition Addict
 
Join Date: Jul 2007
Posts: 5,627
Thanks: 7
Thanked 15 Times in 15 Posts
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
I would start by checking all grounds, and all the connections, and make sure that there is no corrosion. Have the batteries load tested individually.
ianstew is offline  
post #5 of 8 Old 08-23-2012, 06:14 PM
Powerstroke.org Fanatic
 
a.alford's Avatar
 
Join Date: Jul 2012
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i would bet that there is a bad ground somewhere and the poor connection wont allow the truck to start

'00 F-350 7.3 6637 mod with php tunes.
a.alford is offline  
post #6 of 8 Old 08-24-2012, 02:10 AM
Powerstroke.org Rookie
 
Join Date: Jul 2012
Location: Bryant, AL.
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Auto or stick?? Dead as in no power what so ever or you have power when tthe key is on it just won't start? Reason I ask is because my 6sp did that to my sin in law..... he thought the batteries were going bad. It ended up being the clutch safety switch, you mash the pedal to the floor acts like bad batteries. Ease the clutch out just a little it would start right up........
Coops99SD is offline  
post #7 of 8 Old 08-24-2012, 03:29 AM
Christ Follower

 
7.3Excursion4x4's Avatar
 
Join Date: May 2010
Location: Mount Pleasant, SC
Posts: 513
Thanks: 6
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
Feedback Score: 0 reviews
Had the same problem a couple months back and ended up going through 4 new batteries and 2 alternators. Couldn't figure out why at speed the alternator was only putting out 11 volts and at idle was putting out 10.5 or so. Ended up cleaning everything and coating with battery corrosion protection spray and it ended up being the ground going to the block. Ever since, 13.5 at idle and 14.5 running. Took a few hours but worth it.
Good luck

381,000
PHP Hydra
Stage 1 Full Force Injectors
MBRP 4" Turbo Back
F-650 Dash w/EV2 Gauges
CT Performance Suspension
Firestone Ride Rite
DieselSite 4R100, Adrenaline HPOP, WW2
DieselSite Engine & Intercooler Boot Kit
DieselSite Tranny & Coolant Filters
SSBC V8 kit with EBC Rotors
NCHornet's CCV, Swamps IDM
Derale Atomic Cool
6.0 Trans Cooler, Cat ELC Coolant
Mag Hytec tranny pan


7.3Excursion4x4 is offline  
post #8 of 8 Old 08-24-2012, 08:05 AM
Compression Ignition Addict
 
Tj Krawler's Avatar
 
Join Date: May 2010
Location: Western New York
Posts: 958
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
When you say "dead" do you mean it just won't crank? Or the batteries are weak/dead?

Alan
2000 F-350 CC LB DRW 4x4 XLT Auto

- Intake
- Exhust
- ScanGauge
Tj Krawler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome